• Updated plugin to new version 2.0.
    Can’t get rid of (annoyingly red) error message on top of all my admin screens saying

    There’s been an error posting your Twitter status! Visit your WP to Twitter settings page to get more information and to clear this error message.

    I even applied for a cli.gs account (had no url-shortening first) to try and remove the error, but I can’t find what’s wrong!?

    Update: found the “Clear error messages” button, so now it’s gone, but I still don’t know what, if anything, was wrong!


Viewing 14 replies - 1 through 14 (of 14 total)
  • I had the same problem, I had “no url-shortening” set as well and I could bet the button wasn’t there when I tried to get rid off the red message at first (or maybe I was just blind).

    Thanks for mentioning the button, helped me as a charm.

    Thanks for your comments – maybe I need to make that button larger…

    Having no URL shortening should be working – I’ll check it out again, though. You may wish to try again; this could be a hold over caused by settings which no longer exist in version 2.0.

    Same error here using bit.ly

    The user and api key is OK but the plugin still giving me the error.

    Thanks for help

    Same problem here. Using bit.ly URL shortener. The error messages started to appear after upgrading WP To Twitter to version 2.x. I’m using 2.0.1 now.
    I never had that problem before upgrading. Now it appears randomly. But the posts seem to be tweeted despite of the error messages.

    This error is killing me

    I tried bit.ly, cli.gs non of them work, I tried alomst every way

    but the same error message, sometimes posting to twitter without shortening, and after upgrading to wpmu 2.9.2

    it’s not working any more

    I looked around for an answer but no avails, I checked bit.ly and cli.gs blogs but nothing helped

    Please joedolson, I love this plugin and I need it simple and easy to be customised

    I think I´m having the same problem here. Using version 2.0.3 The error I get is:

    The query to the URL shortener API failed, and your URL was not shrunk. The full post URL was attached to your Tweet. Check with your URL shortening provider to see if there are any known issues.

    I don´t know what I´m doing wrong. I´ve inserted bitly API key, username, also for Twitter…. what is missing?.

    Thanks for your help.

    i’m having the same problem and using bit.ly

    i’ve verified my user name and have even reset my api key. no change. when i ran the server test, it provided this error message . . .

    WP to Twitter was unable to contact your selected URL shortening service.
    WP to Twitter successfully submitted a status update to your primary update service.
    Your server should run WP to Twitter successfully.

    hey . . . try http://twitterfeed.com instead . . . you don’t need a plug in at all!

    Same problem here. I get the “error posting status” every time I post. And it’s a false alarm, because the article is posted fine on Twitter, despite the error message. It’ very disturbing to have a red error message at the top of your WP Admin Panel all the time.
    I’m using latest version of WP To Twitter and WP 2.9.2.

    I tried Twitterfeed.com but it was pretty useless. It could only check every half hour and post max 5 post at a time. And it also posted BOTH title and the beginning of the article text.
    With WP To Twitter you can select only the title AND it gets posted on Twitter right after it’s published. Not half an hour later.

    New version of WP To Twitter out now. I think this version will fix the problems:



    * Added a control to disable error messages.
    * Separated URL shortener errors from Twitter API errors.
    * Added stored value with the error message from Bit.ly to try and identify source of errors.

    Unfortunately I tried 2.1.1 and was still getting the errors. I think it slows down posting quite a lot too, I kept getting timeouts. I’ve disabled the error logging for both now and will continue testing like this.

    Yep, same here.

    Without shortening I do get the error, but is does get posted.

    With shortening I get an error telling me bit.li or Cli.gs is not working and the message is saved.

    There’s been an error shortening your URL! Visit your WP to Twitter settings page to get more information and to clear this error message.

    There’s been an error posting your Twitter status! Visit your WP to Twitter settings page to get more information and to clear this error message.

    It does look like a really solid widget though!
    2 thumbs up!

    Im using 2.2.2 btw en WP 3.0.1

    You will get this error if you do not configure your “Basic Settings”. When initially installing this plugin, it leaves the default URL shortener to Cli.gs as the URL shortener whether you use Cli or not. Open “Basic Settings”, go to the bottom drop down menu where it says “Choose your short URL service (account settings below)”. Change it to whatever URL service you are actually using or don’t shorten URLs.

    This error drove me nuts for an hour until I ran into that drop down and selected Bit.ly, which is what I’m using. Now the error is gone. Maybe if there’s a way to either put some kind of warning that tells that in the plugin or make that drop down select your URL shortener service automatically once it’s set in “URL Shortener Account Settings”.

    P.S. and yes Twitterfeed blows … unless you don’t mind your posts showing up a month later. Of course I’m over exaggerating but when using Twitterfeed, my posts would show up a whole 24 hours later at least. And all support says is they’re working on it … well its been like that for months. I stopped using it long time ago.

    I have the some issue..But I think the problme is my CentOS Server..

    I tried to install OAUTH and Re-install Mysql..But the error is still

    remanding me..Anybody know how to solve it?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: WP to Twitter] error posting status’ is closed to new replies.