WP to Twitter
[resolved] 401 auth failed, communications error with twitter (5 posts)

  1. netflow
    Posted 4 years ago #

    Strange thing now is that when I enter in alt he twitter information and click on 'connect to twitter' it doesn't look like it is connecting.. the screen refreshes but all the text boxes are still open for edited and that connect to twitter button is still there. there's not disconnect button anymore.. this might be an upgrade thing but I dunno.

    When I got to post a new post I get the standard 401 auth error messages telling me that it can't connet to the twitter servers:

    One or more of your last posts has failed to send it's status update to Twitter. Your Tweet has been saved in your post custom fields, and you can re-Tweet it at your leisure.

    401 Unauthorized: Authentication credentials were missing or incorrect.

    Sorry! I couldn't get in touch with the Twitter servers to post your new blog post. Your tweet has been stored in a custom field attached to the post, so you can Tweet it manually if you wish!

    Access level in twitter is set to: Read, write, and direct messages

    In my debug messages I'm seeing this:

    [content_type] =>
    [http_code] => 0
    [header_size] => 0
    [request_size] => 0
    [filetime] => -1
    [ssl_verify_result] => 0
    [redirect_count] => 0
    [total_time] => 0
    [namelookup_time] => 0
    [connect_time] => 0
    [pretransfer_time] => 0
    [size_upload] => 0
    [size_download] => 0
    [speed_download] => 0
    [speed_upload] => 0
    [download_content_length] => -1
    [upload_content_length] => -1
    [starttransfer_time] => 0
    [redirect_time] => 0

    WordPress is upgraded, plugin is upgraded, bottom line is the damn thing isn't working and I haven't a clue why not..


  2. Mbenjwal
    Posted 4 years ago #

    i am sure your twitter access token is read only

    make that read and write :-)

  3. erhangulsum
    Posted 4 years ago #


    read and write
    and all others tried but cant connect. i am not new with wp and this plugin but something going wrong... please fix it...

  4. myersmediagroup
    Posted 4 years ago #

    having the same issue.

  5. myersmediagroup
    Posted 4 years ago #

    if you didn't find the answer or for anyone looking:

    "...It's important to set the Application Type Access to "Read and Write" and only AFTER THAT we have to request a token.
    The token's access level inherits the App's access level.
    I had to delete my app and create a new one because revoking the app in Twitter was in vain. It didn't "release" the token in my app.
    Now it works flawlessly. I'm going to use it with bit.ly...."

    Create the app but do not request the two keys/oath things at the bottom, yet. Go to the Settings tab on the same screen and change permissions to Read and Write, save. Go back to the first tab and then request.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP to Twitter
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic