WordPress.org

Support

Support » Plugins and Hacks » wp Time Machine » [Resolved] [Plugin: wp Time Machine] Please update javascript

[Resolved] [Plugin: wp Time Machine] Please update javascript

  • Hello.

    @paulgpetty :
    First, I’d like to thank you for wp Time Machine, it’s very useful.
    But recently I had some trouble with this plugin : it loads some out of date javascripts (for jQuery 1.3.2). My problem is those scripts are messing with other WordPress plugins and jQuery 1.4.4.
    For me, it’s jquery.validate.js 1.6 (in version 1.8.1 now), it emulates a “delegate” function, which exists now in jQuery 1.4.4, so it’s not possible to use the real jQuery delegate function.

    So please, could you update the scripts loaded in wp Time Machine?

    Thank you, Greg.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author paulgpetty

    @paulgpetty

    Just released an update that does a better job of avoiding conflicts if you havejQuery & uses a newer version if you don’t …

    Plugin Author paulgpetty

    @paulgpetty

    A separate update (1.9.18) addresses jquery.validate.js

    Hello paulgpetty.

    Yes I saw it, I was amazed (“Wow, that was quick!” ^^).
    But my problem was not with jQuery itself (WP admin loads jQuery 1.4.4), but jquery.validate.js, which doesn’t play well with the delegate() function (appeared in version 1.4.2 of jQuery), because it also creates a function called delegate().

    Anyway, I “solved” my problem by replacing jquery.validate.js (version 1.6 in your plugin) by the last version 1.8.1. Another solution is to use live() in my script instead of delegate().

    I only posted here because some other plugins could use delegate() and have this problem too.
    Thanks again for your plugin. See you.

    Ho ok, I only have the 1.9.17. Thank you for 1.9.18!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] [Plugin: wp Time Machine] Please update javascript’ is closed to new replies.
Skip to toolbar