Support » Plugin: WP-Table Reloaded » [Plugin: WP-Table Reloaded] Unknown parameter error

  • Resolved sturtos

    (@sturtos)


    Hello,

    When I view a new table I imported, I am getting the following error:

    “DataTables warning (table id = ‘wp-table-reloaded-id-4-no-1’): Requested unknown parameter ‘3’ from the data source for row 11”

    I deleted row 11 and replaced it. I’ve also checked my css changes just in case. Unfortunately, I can’t tell what is causing this error. Any thoughts?

    Thanks!

    http://wordpress.org/extend/plugins/wp-table-reloaded/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble that you are experiencing. Unfortunately, it’s hard for me to help without seeing the actual table and error. Can you therefore please post the URL to the page with your table where this happens?

    Thanks!
    Tobias

    Thanks Tobias, sorry for the delayed response. I’m having trouble with 2 tables:

    http://guidesunvalley.com/bike/rent-bikes/

    http://guidesunvalley.com/ski/rent-skis/

    Thanks!

    Tobias, while you are looking at the ski rental page, could you also look at my css (below) and tell me what might be wrong?

    The alternating row colors aren’t working but I’m using the same code that works on other tables.

    Thanks!

    [CSS moderated as per the Forum Rules. Please just post a link to your site.]

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for the links!
    The reason for these error message is the usage of the #colspan# feature together with the features of the DataTables JavaScript library (sorting, search, pagination, …). Unfortunately, these two things can’t be used together.
    For your tables, the best choice is to simply deactivate the DataTables library, as the features are not that necessary anyway. To do that, just go to the “Edit” screens of the tables and uncheck the “Use JavaScript library” checkboxes.

    After this, the alternating row colors should also work again, as they are also influenced by that error from above. Your CSS code looks totally fine.

    Regards,
    Tobias

    Thanks Tobias, much appreciated! I made a donation in thanks!

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    no problem, you are very welcome! And thanks for the donation, that’s really nice!

    Best wishes,
    Tobias

    I am getting the same error message and I can’t find any “colspan” or “rowspan” in the table. How do I find a hidden “colspan”?

    John

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi John,

    can you please post a link to the page with your table? Maybe I can find out what’s going on.

    Regards,
    Tobias

    Sure! Thanks for taking a look at this for me.

    http://www.gssalliancetables.com/2011/11/string-characteristics/

    John

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi John,

    thanks for the link!

    The reason for this error message is some invalid HTML in your table.
    When you scroll down, you will see a few rows that have dark grey cells in the last column. In each of these rows, there’s a problem in the HTML for the link in the second column. In a few places, it’s a missing quotation mark " after the URL, and before the closing > of the <a href=...> tag. In some other places, there seems to be a line break after the <a in those tags.
    Can you check that and fix the HTML there? After that, the error message should disappear.

    Regards,
    Tobias

    Tobias, thank you for the reply. I will look into it now.

    John

    Tobias, I was able to correct the situation using your instructions.

    Thank you!

    John

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi John,

    very nice! Thanks for the confirmation!

    I just spotted to more of those line breaks, I mentioned.
    In the second column for row 66 (“Tecnifibre XR1 17”) and of row 114 (“Groom Sports White 1.15)”, there’s a line break directly after the <a. You will easily see that when dragging the text field wider. I suggest that you remove those line breaks there.

    Best wishes,
    Tobias

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: WP-Table Reloaded] Unknown parameter error’ is closed to new replies.