Support » Plugin: WP-Table Reloaded » [Plugin: WP-Table Reloaded] Table not showing (blankpage)

  • Hello there.

    first This is a great plug-in !

    But I’m posting because I encounter a pb I can’t resolve :

    I’ve got a quite big file (380 lines) I wish to show.
    – importing is fine (either way with CSV or copy and paste)

    If table get under 100 lines all is showing fine.
    maximum I’ve been able to get is 346 lines… at the 347 line the page is blank.
    no error message is showing (I’ve also tried debug mode is WP but no indication too).

    I don’t understand. I’ve played whith SQL and increase to 128,256 and 512 Mb but no changes.
    => this is all I’ve changed :
    SET GLOBAL query_cache_size =512000000
    SET GLOBAL max_heap_table_size =64000000
    SET GLOBAL tmp_table_size =64000000

    No go.
    in WP settings I’vegot 128M
    in PHP settings too.

    I can’t get it to work and I’ve no idea why (besides I’m not a big developper too, just a curious guy that hate to not understand things !)

    I won’t have many table that big but I’d really like to get this one displaying.

    I’m using ellegantheme but I don’t think this is the pb.

    and again with small tables like 30-50 lines I ain’t got no b at all. tables are diplaying on the post or the page.

    Can someone point me to something to look at ?

    Also I’m on a intranet so I cannot give url for anyone to look at it !
    I also don’t have the power to change php settings directly if needed, but this can be done (with some delay).

    don’t see what more to tell.

    And yeah, Pardon my bad english, I’m a french guy 😉

    My best…

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author TobiasBg


    Hi tobias,

    thank for this very quick answer

    I’ve read your links and I’ve checked phpinfo. you are right the suhosin plugin is there.
    I’ll ask the server admin to increase as stated in your links to see if all is going back to normal.

    Many thanks I’ll keep this post updated as soon as I’ve got answer from the server admin.

    many thanks !

    After many hours of searches if found a lead for the culprit but not found the solution yet.

    As I stated this is on an intranet so I cannot give url 🙁

    I have installed a second test server (debian) : ZEUSERV
    (I’ve got full root power on this test server)
    We use the blog on the Production server (debian) : PRODSERV
    I ain’t got any power on this server – I didn’t installed it neither.
    Both have the same distribution, same wordpress.

    THEMES (it is related)
    I use the elegantthemes “Theprofessional”
    (I know I won’t have support for this theme here but it is a lead and I’ll post the exact same topic on the eleganttheme forum as well)
    but as you’ll see below this is somehow related.

    The table I want to use has 378 rows.

    I have changed values for suhosin see below…

    Thread on wordpress wp-tables-reloaded (this topic 😉 ) :
    Thread on elegant themes (must be logged in) :

    ==== ON ZEUSERV ====
    Theme “TheProfessionnal Elegantthemes”
    if not logged in  : Table is displayed
    if logged in  : I got a blank page

    Theme “Twentyten” par défaut
    if not logged in  : Table is displayed
    if logged in  : Table is displayed

    ==== ON PRODSERVER ====
    Theme “TheProfessionnal Elegantthemes” (que j’utilise depuis le début donc)
    if not logged in  : I got a blank page
    if logged in  : I got a blank page 

    Theme “Twentyten” par défaut
    if not logged in  : Table is displayed
    if logged in  : I got a blank page

    === blank page ====
    Here is the html output when I got a blank page :


    ==== SUHOSIN ====
    to get acces and mostly to be able to overide settings I’ve installed the suhosin module as the php of dean is patch by suhosin and any changes to a config isn’t load unless the module is installed (for me at least)

    I’ve change many values to 2048 to get a big margin
    values like : 2048 2048
    suhosin.request.max_vars 2048
    suhosin.request.max_array_index_length 2048
    suhosin.cookie.encrypt Off
    suhosin.cookie.max_vars = 2048
    suhosin.memory_limit = 201326592
    suhosin.get.max_vars = 2048

    (BTW you’ll se I’ve set the cookie encryption to off on my zeuserv) but no go with the elegant theme, ok with twentyten theme.

    === COOKIES ===
    After analyzing phpinfo on both server (In fact I have a third one installed by the admin so it is a clone of the PRODSERV)
    I’ve got a HTTP_COOKIE showing on PRODSERV but I have not this on ZEUSERV : this explains the difference between the two results.

    So definitely the theme somehow doesn’t help, but in any case this is a cookie related problem.

    Lost of test to find this out.
    I’ll continue with the suhosin settings

    ==== virtual hosts ====
    Another things is that on PRODSERV the admin managed virtual host on apache2. I did not on ZEUSERV.

    I’ m quite sur this doesn’t help with the cookie stuff !

    I don’t see other things I could add, and if:
    Tobias you could indicate me if and where if so) you managed cookie in your plug-in that would be nice !
    Anyone had a clue that would be super nice 😉

    My best…

    Plugin Author TobiasBg



    thanks for your further investigations!
    This really is weird issue.

    Additionally to the Suhosin settings, please try to increase the PHP memory limit (e.g. by increase the value of the “WP_MEMORY_LIMIT” constant). That might also be the reason for the problem.

    And can you take a look into the error logs of your server?

    For the cookies: WP-Table Reloaded does not use any cookies. Only WordPress uses cookies for the authentification.


    OK I’ll look at this… but memory limit has been hugely increased if my memory is right.
    Also we do’nt have anything on the logs !
    we’ve tried php and apache logs, enabling debug modes in WP I even installed a plug-in for debuging but nothing shows nowhere ?
    the other admin and I are completely lost.

    I’ll double check the memory stuff and just to be sure and look further in suhosin cookie settings too.

    I also think the virtuals host is also tweaking and interacting with the cookies because HTTP_COOKIES and virtual host are the TWO difference between ‘my’ test server and the ‘prod’ server.

    anyway I’ll keep the topic posted.

    thank you for your quick answer !

    Hello Tobias,

    just to tell you that for sure the plugin is not the pb. 100% sure.

    I explain I’ve now discover that when I click on a category on my menu, if the category contains many posts => guess what I’ve got a blank page ! ;(

    In a way the theme from eleganttheme doesn’t help… but it is not the fully culprit.

    SO if anyone as a clue reading this ! you’re very welcome to help get a way to fix this 😉
    but it ain’t nothing to do with the plugin.

    I don’t know how to debug this but won’t give up.

    I”ll try on another server like my OSX box (with no SUHOSIN at all) just to understand WTF is going on.

    For sure I’ll inform here if I’ve resolved this damn anoying behavior.


    Plugin Author TobiasBg



    thanks for those details! I really hope that this can be fixed, and maybe somehow else has an idea, yes.

    Just from curiosity: What value have you set WP_MEMORY_LIMIT to?


    I made it !
    was suhosin as you stated. I need to confirm this on the prod server, but now I can see the table with my theme and all is fine.

    I’ll try to optimize the suhosin settings later on, to see what the limit is.

    My guess is that the theme was increasing the ‘get’ request as this is here taht I just did the changes !

    I’ve set the WP_MEMORY_LIMIT to 64 and more but no effect as it is suhosin who deals that. I’ve put 201326592 (bites?) and wasn’t enough as I saw it in the log (this time) saying requesting more than alllowed, so I went to 291326592… and it disapeared from the log.
    I’ll set this to higher level I guess as I’ll have many posts and topics to come 😉

    Anyway, that didn’t help for the table display. (only the ‘get’ suhosin options made it – I changed also post etc… but that was before and again I finally got it with the get options.

    I’m glad I can use the plugin now. Was so fustrated some were able to have 900 rows and not me 😉

    Many many thanks Tobias, you’re the man !

    Just to help other that may have similar problems :

    suhosin settings I’ve changed
    !!! I’m on an INTRANET !!! this server isn’t visible from internet, only in our LAN or by VPN, so I’m not that concerned with some eventualy secuirty concerns, ut as I said I’l try to decrease all values to the max possible just to do things fine. for now it is working.

    So basically here are the suhosin options I used :
    ( I know this is extreme but I’ll decrease later on for the reasion I gave above)

    [begin of file]

    ; configuration for php suhosin module
    ; Module Settings ;
    ; the following values are the internal default settings and set implicit
    ; feel free to modify to your needs
    ; Logging Configuration
    ;suhosin.log.syslog.facility = 9
    ;suhosin.log.syslog.priority = 1
    ;suhosin.log.script = 0
    ;suhosin.log.phpscript = 0
    ; =
    ; =
    ;suhosin.log.use-x-forwarded-for = off
    ; Executor Options
    ;suhosin.executor.max_depth = 0
    ;suhosin.executor.include.max_traversal = 0
    ;suhosin.executor.include.whitelist =
    ;suhosin.executor.include.blacklist =
    ;suhosin.executor.func.whitelist =
    ;suhosin.executor.func.blacklist =
    ;suhosin.executor.eval.whitelist =
    ;suhosin.executor.eval.blacklist =
    ;suhosin.executor.disable_emodifier = off
    ;suhosin.executor.allow_symlink = off
    ; Misc Options
    ;suhosin.simulation = off
    ;suhosin.apc_bug_workaround = off
    ;suhosin.sql.bailout_on_error = off
    ;suhosin.sql.user_prefix =
    ;suhosin.sql.user_postfix =
    ;suhosin.multiheader = off
    ;suhosin.mail.protect = 0
    ;suhosin.memory_limit = 201326592
    suhosin.memory_limit = 291326592
    ; Transparent Encryption Options
    suhosin.session.encrypt = on
    ;suhosin.session.cryptkey =
    ;suhosin.session.cryptua = on
    ;suhosin.session.cryptdocroot = on
    ;suhosin.session.cryptraddr = 0
    ;suhosin.session.checkraddr = 0
    ;suhosin.cookie.encrypt = on
    ;suhosin.cookie.cryptkey =
    ;suhosin.cookie.cryptua = on
    ;suhosin.cookie.cryptdocroot = on
    ;suhosin.cookie.cryptraddr = 0
    ;suhosin.cookie.checkraddr = 0
    ;suhosin.cookie.cryptlist =
    ;suhosin.cookie.plainlist =
    ; Filtering Options
    ;suhosin.filter.action =
    ;suhosin.cookie.max_array_depth = 100
    suhosin.cookie.max_array_depth = 1000
    ;suhosin.cookie.max_array_index_length = 64
    suhosin.cookie.max_array_index_length = 640
    ;suhosin.cookie.max_name_length = 64
    suhosin.cookie.max_name_length = 640
    ;suhosin.cookie.max_totalname_length = 256
    suhosin.cookie.max_totalname_length = 2560
    ;suhosin.cookie.max_value_length = 10000
    suhosin.cookie.max_value_length = 100000
    ;suhosin.cookie.max_vars = 2048
    suhosin.cookie.max_vars = 20480
    ;suhosin.cookie.disallow_nul = on
    ;suhosin.get.max_array_depth = 50
    suhosin.get.max_array_depth = 256
    ;suhosin.get.max_array_index_length = 64
    suhosin.get.max_array_index_length = 256
    ;suhosin.get.max_name_length = 64
    suhosin.get.max_name_length = 256
    ;suhosin.get.max_totalname_length = 256
    suhosin.get.max_totalname_length = 256
    ;suhosin.get.max_value_length = 512
    suhosin.get.max_value_length = 512
    ;suhosin.get.max_vars = 400
    suhosin.get.max_vars = 2048
    ;suhosin.get.disallow_nul = on
    ; = 400 = 2048
    ; = 64
    ; = 256
    ; = 65000 = 2048
    ; = on
    ;suhosin.request.max_array_depth = 100
    suhosin.request.max_array_index_length = 2048
    ;suhosin.request.max_totalname_length = 256
    ;suhosin.request.max_value_length = 65000
    suhosin.request.max_vars = 2048
    ;suhosin.request.max_varname_length = 64
    ;suhosin.request.disallow_nul = on
    ;suhosin.upload.max_uploads = 25
    ;suhosin.upload.disallow_elf = on
    ;suhosin.upload.disallow_binary = off
    ;suhosin.upload.remove_binary = off
    ;suhosin.upload.verification_script =
    ;suhosin.session.max_id_length = 128

    [end of file]

    extreme i Know but working 😉


    the final explanation !
    it was an option of another plugin that was messing everything beside the suhosin limitations.

    the plugin is Mailto plugin.
    the option to uncheck is :
    Options have effect on => All contents (the whole <body>)
    just unchecking this option and it’s ok. you can still check options below
    Options have effect on => Post contents
    Options have effect on => Comments
    Options have effect on => Text widgets

    weeks, days to find this out !

    I can now use wp-table-reloaded and my elegantthemes theme !

    Now I’ll go down on suhosin as it finally maybe wasn’t in fault.

    My very best…

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: WP-Table Reloaded] Table not showing (blankpage)’ is closed to new replies.