WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP-Table Reloaded] Large table very slow to view in admin

[Plugin: WP-Table Reloaded] Large table very slow to view in admin

  • joesmalley
    Participant

    @joesmalley

    I have a 200 row table with 10 columns. If I click on ‘edit’ in admin for this table, the edit page takes around 1 minute to show, since it has to create a form with 2000 table input areas. If I save it, it takes another minute, plus a further minute to show the new edit page. It makes editing something simple (like the table name) very slow.

    Is there a way (or perhaps you could include this in future versions) to disable this edit table content area unless enabled? Or perhaps it could be automatically disabled if there are more than 50 rows.

    http://wordpress.org/extend/plugins/wp-table-reloaded/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author TobiasBg
    Participant

    @tobiasbg

    Hi,

    yeah, I know this stupid issue. Unfortunately I don’t really see a possibility to do something about it at the moment, due to the current structure of the saving mechanism of the plugin.
    Disabling the textfields is not an option because of that, sorry.

    Best wishes,
    Tobias

    joesmalley
    Participant

    @joesmalley

    Hi Tobias,

    This problem is still causing me problems on a website, I wondered if there’s a work-around for it? Or if you could be at a stage to tackle it now?

    It would really be beneficial to limit editing rows to say, 50 rows at a time, with pagination to edit the other rows.

    Plugin Author TobiasBg
    Participant

    @tobiasbg

    Hi Joe,

    no, unfortunately, there’s nothing new here, sorry 🙁

    You could try to deactivate the autogrow for the textareas on the “Plugin Options” screen, that might reduce the load of the JavaScript a little bit.

    I like the idea of pagination, but as mentioned above, the data structure currently limits this 🙁

    Regards,
    Tobias

    franck
    Member

    @franckmercado

    Hi Tobias, great plugin, congratulations.

    I have this issue: I have a 1000 rows table with 5 columns, it takes some seconds to load but it does. I recently change hosting provider and now the table loads half the way.

    I think your plugin needs some minimum server requirements like max_execution_time and memory_limit. what configuration would be adequate?

    thank you
    franck

    Plugin Author TobiasBg
    Participant

    @tobiasbg

    Hi Franck,

    thanks for your question.

    Just to be sure: When you say “half the way”: Is there anything showing after those cells (like the table styling options), or does the page really stop right amongst the table cell textfields?

    And yes, you are right that increasing the requirements on the server might help. I don’t have direct values, but in general 128MB of memory and 30s of execution time should be enough.
    If not, I would actually recommend to no longer use WP-Table Reloaded for this large table, but to develop a custom solution using PHP/mySQL.

    Regards,
    Tobias

    franck
    Member

    @franckmercado

    my hosting provider just set php configuration to this values:
    max_execution_time: 60
    memory_limit: 128M

    but i have no success trying to load the table in the admin section. it still stops just showing me 100 or 200 rows and there are no other options below that table

    by the way it works perfectly well in local machine so it has to be something with the server configuration … what other option could I change in the server to solve this loading issue?

    Thanks in advance.

    Plugin Author TobiasBg
    Participant

    @tobiasbg

    Hi,

    unfortunately, I don’t really know what other options need to be changed to make this work, but if you want, I can take a direct look at your Admin Dashboard, to see what is going on.
    Can you therefore contact me by email (the address is in the main plugin file “wp-table-reloaded.php”).

    Regards,
    Tobias

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: WP-Table Reloaded] Large table very slow to view in admin’ is closed to new replies.