Support » Plugins » [Plugin: WP-Table Reloaded] Inserting audio player into tables

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hi,

    this happens because the Audio Player plugin does not use regular WordPress Shortcodes, but its own version – which do not work out of the box in tables.

    You can easily make them work by adding the following line of code to the file “functions.php” of your theme.

    add_filter( 'wp_table_reloaded_cell_content', 'insert_audio_player' );

    Best wishes,



    Hi Tobias, i have the same problem, i’d add the filter to the file funtions.php but nothin’ happens. Can you help me?
    My idea is to make a song list like a ranking but with the ability of play each song.
    Sorry ’bout my english, not my first.


    do you have the “Audio Player” plugin installed? That’s necessary for the Shortcodes to work of course.

    If yes, can you provide a link to the page with the table?




    Thanks for the quick response!
    I’m running the site locally for testing pourposes, but i create a page in another site and the same thing happend here’s the link

    i created 2 table, the first with shortcode, the audio player apears but outside the table with all the data.

    The second without the shortcode but no data is shown

    and finally before filter install in functions.php, tables work fine with correct height, and showing all data, and when i copy the code in functions.php the tables look like this

    I hope that you can help me and one more time sorry my english


    ok, it is very weird that your tables are totally empty…
    This let’s me assume that the “insert_audio_player” function has somehow changed.
    I believe, instead of returning a value, it is echoing it. That would explain both of the issues.

    Can you post a link to the exact plugin you are using for the Audio Player (I want to be sure, because there are several different ones.)?

    Then I should be able to find the correct code for you.

    Best wishes,

    P.S.: And don’t worry about your English! 🙂

    P.P.S.: Also, I might not be able to answer again until Monday, because I will be on a small vacation.



    This is the player’s link
    One thing, in the first table, the shortcode works, data is there but outside the table (all text above the table is part of it).

    Thanks and have nice vacations

    Hi Ricardo,

    good news: As you were so quick with your answer, I have not yet left for vacation 🙂

    Here is the solution. Please try again with this code in the functions.php

    add_filter( 'wp_table_reloaded_cell_content', array( &$AudioPlayer, 'processContent' ), 2 );

    The code presented above is no longer correct (as I had assumed, the function echoed its return value instead of just returning it, which is necessary). The new code should behave correctly 🙂

    Best wishes,



    Now works perfectly!!
    check it out

    Very very thanks, you help me a lot

    Hi Tobias, I also want to do this, using the same audio player, but haven’t edited a .php file before.

    This is the last few lines of my functions.php file.

    Where do I add the piece of code, and do I add ‘function’ before ‘add_filter etc.’ and do I need to add any { and } as well?

    Thank you in advance for your help!

    function _wp_mysql_week( $column ) {
    switch ( $start_of_week = (int) get_option( ‘start_of_week’ ) ) {
    default :
    case 0 :
    return “WEEK( $column, 0 )”;
    case 1 :
    return “WEEK( $column, 1 )”;
    case 2 :
    case 3 :
    case 4 :
    case 5 :
    case 6 :
    return “WEEK( DATE_SUB( $column, INTERVAL $start_of_week DAY ), 0 )”;



    just put that one line from above right before the ?> at the end of the file. Nothing else, no function or any {}.


    Yes, marvellous!
    Thank you very much — also for the great table plugin!
    Best wishes, Clare

    Hello Tobias and all,

    I am making a website for a friend. I used wp-table reloaded to organise his mp3 tracks and applied the code above to enable the audio player to load.

    My problem comes in later: when I’m logged into my wordpress dashboard and view the page, it works fine but if I am not logged in, the audioplayer doesn’t appear.

    I don’t know what I’m missing.

    UPDATE: I was scrolling through the options for the table in question and noticed the “Cache Table Output” option. Disabled that and it did the trick. For some reason that was interfering. (I don’t know if it’s related to the browser cache but I had cleared mine and also tried from multiple computers and smartphones)

    Anyways, just thought I would contribute my findings.


    thanks for this! Yes, the “Cache Table Output” functionality might have something to do with this, so turning it off is a good step here.

    Best wishes,

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: WP-Table Reloaded] Inserting audio player into tables’ is closed to new replies.