WordPress.org

Support

Support » Plugins and Hacks » WP-Table Reloaded » [Resolved] [Plugin: WP-Table Reloaded] Data Table warning

[Resolved] [Plugin: WP-Table Reloaded] Data Table warning

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author TobiasBg

    @tobiasbg

    Hi,

    the problem seems to be that you are using the #colspan#/#rowspan# feature and the DataTables library in this table, at the same time. This is not fully supported by the library and therefore gives an error message now. (Before the update, the library just failed silently.)

    To change this, simply uncheck the “Use JavaScript library” checkbox on the table’s “Edit” screen.

    Regards,
    Tobias

    Thanks Tobias – great plugin ๐Ÿ™‚

    Plugin Author TobiasBg

    @tobiasbg

    Hi,

    no, thank you ๐Ÿ™‚ Nice to hear that you like it!

    Best wishes,
    Tobias

    Thank you for your help! Great Plugin. I do use it for my brazilian website. Now i can add more visual content to my posts and it pleases the readers.

    All the best for you Tobias!!

    Are there more plugins you are working with?
    ๐Ÿ™‚
    Fรกbio

    Plugin Author TobiasBg

    @tobiasbg

    Hi Fรกbio,

    thanks for your kind words! It’s great to hear that you like the plugin so much!

    And, no, so far this is the only plugin that I actively develop ๐Ÿ™‚

    Best wishes,
    Tobias

    Thank you, and great plugin!

    Plugin Author TobiasBg

    @tobiasbg

    Hi,

    sure, no problem! ๐Ÿ™‚ You are very welcome!

    Regards,
    Tobias

    hi TobiasBg,

    I am developing a project using ThemeForest Zice Admin template. In my project I have a search functionality based on multiple id’s, if the data is found I disply that data into a table, in the same jsp page and in that jsp I have 4 tables and I display only one table at a time based on the search.

    In that table I have a link field, when I press the link it display a popup form and show the table data in that form.

    My problem is I got the following warning message as popup and styles to the table are not applied…….

    DataTables warning (table id = ‘journalTable’): Requested unknown parameter ‘4’ from the data source for row 0

    When I search in google, I saw your solution………simply uncheck the “Use JavaScript library” checkbox on the table’s “Edit” screen……

    but I dont know where to unchek and how to do……… because I dont know javascript………..Please help me……

    Plugin Author TobiasBg

    @tobiasbg

    Hi,

    my solution only applies to tables that where created with the WP-Table Reloaded WordPress plugin. Your error message hints that you are not using this plugin, but some other solution that also uses the DataTables JavaScript library (which actually raises this error).

    If you post the link to the page with your table, I can try to help.

    Regards,
    Tobias

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] [Plugin: WP-Table Reloaded] Data Table warning’ is closed to new replies.
Skip to toolbar