Support » Plugin: WP-Table Reloaded » [Plugin: WP-Table Reloaded] CSV import makes empty rows

  • I’ve been doing some workflow tests and noticed that importing CSV files saved from Excel results in a LOT of empty rows at the bottom.

    However importing CSV files downloaded from Google Docs does not have the empty row problem.

    Is there something I’m missing about the way I’m saving Excel CSV files that results in extra rows? I can successfully use Google CSV files that were edited & saved using Excel without the empty row problem so I’m guessing there’s something I’m not doing to the XLS files when exporting from Excel. I just don’t know what it is.

    Any tips?

Viewing 1 replies (of 1 total)
  • Plugin Author TobiasBg



    I don’t really know what Excel does to the CSV files, but maybe you have some rows in your Excel file that are not really “empty”? With that I mean, that likely there is no content in the cells, but maybe you have applied styling to the cells? This could lead to those longer CSV files, maybe (but I’m not sure).

    Anyhow, it should be simple to fix this after the export from Excel: Just open the CSV file in a text editor, like Notepad or WordPad. Then you should see the lines at the end that later come out empty. They will look like


    which is the CSV equivalent of an empty row with five cells.
    Just remove all of those lines until you have reached your actual last row and the subsequent import should not have any extra empty rows.

    If that does not help, you can simply delete the rows on the “Edit” screen of your table in WP-Table Reloaded. Just click the checkbox in front of all empty rows (you can click the first one, hold down the “Shift” key, and click the last one to check all of them faster), and click the “Delete rows” button.

    Best wishes,

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: WP-Table Reloaded] CSV import makes empty rows’ is closed to new replies.