WordPress.org

Ready to get started?Download WordPress

Forums

WP-Table Reloaded
CSS Override somewhere? (2 posts)

  1. krmmalik
    Member
    Posted 4 years ago #

    I created a custom template for a static page on our wordpress site as i didnt want the header, footer and a few other things showing.

    So then i used the plugin to generate a table but everytime i try to add custom css to the custom css textarea, none of the changes seem to take effect.

    I think some CSS may be overriding somewhere?

    Here is the page

    http://xs-pro.co.uk/team/

    and here is the code that i created for the custom template just in case it is the cause of the conflict(?)

    <?php
    /*
    Template Name: Bare
    */
    global $k_options;
    if ($post->ID == $k_options['contact']['contact_page']) $contactpage = true;
    if ($post->ID == $k_options['portfolio']['folio_page']) $portfoliopage = true;
    if ($post->ID == $k_options['blog']['blog_page']) $blogpage = true;
    
     if($contactpage)
    {
    	include(TEMPLATEPATH."/template_contact.php");
    }
     else if($blogpage)
     {
    	include(TEMPLATEPATH."/template_blog.php");
     }
     else if($portfoliopage)
     {
    	include(TEMPLATEPATH."/template_portfolio.php");
     }else{
    
    // get_header(); 
    
    ?>
    
    <link rel="stylesheet" type="text/css" media="all" href="http://xsdev.xs-pro.co.uk/wp-content/plugins/wp-table-reloaded/css/plugin.css?ver=1.7" />
    <link rel="stylesheet" type="text/css" media="all" href="http://xsdev.xs-pro.co.uk/wp-content/plugins/wp-table-reloaded/css/datatables.css?ver=1.7" />
    
    <div id="content" class="bg_sidebar">
               <div id="inner_content">
    
                <?php if (have_posts()) : while (have_posts()) : the_post();
                $punchline = get_post_meta($post->ID, "punchline", true);
    			$portfolio_image = get_post_meta($post->ID, "portfolio-image", true);
    			?>
    
                <div class="entry">
    
               <span class="meta"><?php echo $punchline; ?></span>
               <h2><a href="<?php echo get_permalink() ?>" rel="bookmark" title="Permanent Link: <?php the_title(); ?>"><?php the_title(); ?></a></h2>
    
               <div class="entry-content">
               <?php
               if($portfolio_image != "") echo '<img class="aligncenter" src="'.$portfolio_image.'" alt="" />';
               ?>
               <?php the_content(); ?>
     			</div><!--end entry-content-->
    
    			</div><!--end entry-->
               </div><!-- end inner_content-->
    
               	<?php endwhile; else: ?>
    
    	<p>Sorry, no posts matched your criteria.</p>
    
    <!--do not delete-->
    <?php endif; ?>
    
      <!--
     <?php get_sidebar(); ?>   
    
    </div><!-- end content-->
    
     <?php 
    
     } 
    
    ?>
  2. TobiasBg
    Member
    Plugin Author

    Posted 4 years ago #

    Hi,

    yeah, it looks like your page template might caues the trouble here: It is not producing a valid HTML page. In fact, the entire header and footer is missing. Due to that, not all CSS code is included in the page, and therefore the styling looks odd.

    Regards,
    Tobias

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic