Support » Plugin: WP-Table Reloaded » [Plugin: WP-Table Reloaded] CSS not being applied

  • Resolved vvvv


    Thanks for all of you work on this – very flexible!

    I have a few tables, all of which were working fine for months until a night ago when I cut and pasted a replacement hex color into my css in the plugin option area. Upon doing so, immediately the table that I was editing went to default styles and I cannot get the custom css to apply anymore to ANY of my tables. I have checked for special chars that may have been introduced unknowingly and did not seem to find any.

    None of the tables that had customizations, are seeing the css applied.
    It does appear that the css is in the code and in the db…

    Just wondering what I can do/look for to get this working again.

    Any help is definitely appreciated!

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author TobiasBg



    thanks for your post.

    For some reason, some commas are missing in your “Custom CSS”. Also, you are either missing the table IDs in the CSS or you have not removed a small piece of code (necessary for the case that the CSS shall apply to all tables). For example, the first line

    .wp-table-reloaded-id th .wp-table-reloaded-id .sorting{

    should either be

    .wp-table-reloaded th, .wp-table-reloaded .sorting {

    if that code shall apply to all tables or something like

    .wp-table-reloaded-id-123 th, .wp-table-reloaded-123 .sorting {

    if it shall just apply to one table (ID 123 in this case).

    Also, there’s a closing ) missing in the background-image property in the first block. (My assumption is that this causes your problem.)

    And just to be sure: Have you unchecked the “Use default CSS” checkbox on purpose? (Which is no problem, of course.)


    …oh my, what would we all do without a second pair of eyes! Always so simple once you see it!

    Now what is interesting, is that in the Plugin Options box, the “)” IS there, it just isn’t showing up in the source code of the page… very weird…
    And I had taken the PlOp code out and put it into an html editor to check for mistakes like that and also put it in Word and parsed for hidden characters.. both kept checking out fine. Even today, I see the “)” in the text. Even with updating options several time, the source is still missing it as you have found. I even put in a text test comment to make sure that the file was being saved, and the comment DID show after saving… so that is working…

    I will continue to play with this to see if I can get it to show, but I agree, this will probably be the culprit.

    In answer to your other questions, I did update the first line to correct that error and have the Header Row apply to all tables and yes, the checkbox for Use Custom CSS is/was still checked.

    Thank you so much for the look and for the wonderful plugin!


    I got it!

    But why, I do not know….

    As an attempt to try things, I changed my url from “https” to http and then updated with Saved Options.

    Even though the PlOp returned to https… after the save, the source showed http and the css applied..

    I am running a Force Https plugin, which may be interfering with this.

    So, the css is working, but what shows in the Plugin Options is NOT what is being actually used.

    SO, I’ll play some more to get this figured out, but this was a weird one… thanks so much for the help.

    Hi there,

    please take a look on this post:

    I added this to custom css but the table is not shown with auto-width.

    .wp-table-reloaded-id-1 {
      width: auto !important!
      margin: 10px auto !important;

    I tried the shortcode with coloumn-widths to but nothing happens.
    I also tried to use the css for the coloumns, again nothing happens.

    I think, the css is – for some reason – not applied correctly.

    Can you figure out why?

    whoops! spoke too soon.

    It DID work, so I made one change in a font size ( in a completely different place in the Plugin Options) and it broke again… the “)” is not showing again even though it IS showing in the PlOp

    Boy, any ideas here would sure save me some of the hair off my head!


    I think it is because you are using !important! instead of !important;

    ok, I can duplicate the error now, so I will be able to get around things, but it really isn’t ideal.. I want to post this in case anyone else has this problem or if anyone could point me toward a better solution.

    1.Anytime I make ANY change to the Plugin Options, the error above occurs after saving.

    2. If I set my url to “http” instead of “https”,and Save the Plugin Options, the page will see the css applied, but the code in Plugin Options will go back to “https”.

    So in a nutshell, evey time I make ANY change at all in Plugin Options, I need to reset the code for that background-image to “http”.

    Not the best, and I really would like to know why this is going on.. but at least I can get the table working again.

    Thanks again for the help

    Plugin Author TobiasBg



    thanks for all your investigations on this! This is indeed very weird!
    However, I’m pretty sure that WP-Table Reloaded is not influencing/causing this. More likely, there seems to be some text replacement going on. Typically, this is for example done by caching or CDN plugins. Do you have something like this installed?

    A workaround might be to get rid of the http/https part of the URL: Simply using


    should be enough, as the domain is the same.

    vvvv is correct: The second ! is a typo. If you use

    width: 100% !important;

    your table’s width will increase.


    Yep, that worked too.

    Thanks again – have a good one!

    Plugin Author TobiasBg



    sure, no problem! If you happen to find a cause for this, please let us know!


    That really did the Trick 😉 thank you

    Plugin Author TobiasBg



    thanks for the confirmation, digiblogger! Great to see that this worked!

    Best wishes,

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: WP-Table Reloaded] CSS not being applied’ is closed to new replies.