WordPress.org

Forums

WP-Table Reloaded
[resolved] can't save\update long tables (17 posts)

  1. rytrom
    Member
    Posted 2 years ago #

    Have a table (imported from a file) with almost 800 rows and 5 columns. When try to update it in WP ("update changes" or "save and go back") getting an error: Service Temporarily Unavailable. Other (smaller) tables work fine.

    what to do?

    http://wordpress.org/extend/plugins/wp-table-reloaded/

  2. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    thanks for your report, and sorry for the trouble that you are experiencing.

    From your description, I assume that this is caused by the known "Suhosin" problem. Suhosin is a security extension on the server than can (if configured too strict) break the saving of tables and options (due to which those things you mention don't work). Please take a look at these forums threads for more hints:
    http://wordpress.org/support/topic/plugin-wp-table-reloaded-table-errors
    http://wordpress.org/support/topic/plugin-wp-table-reloaded-table-not-showing-blankpage
    http://wordpress.org/support/topic/plugin-wp-table-reloaded-plugin-wp-table-reloaded
    http://wordpress.org/support/topic/plugin-wp-table-reloaded-row-limitations

    Another reason might be that the PHP Memory Limit is reached, so that the saving process simply stops. Can you try to increase the limit by following http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP ?

    Regards,
    Tobias

  3. j-prause
    Member
    Posted 2 years ago #

    I had the same problem like rytrom above. Many tables being updated successfully yet a large one of the same type failed.
    I forced error logging. Error log shows
    PHP Warning: Unknown: Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini.
    I used .user.ini to increase the limit:
    max_input_vars = 2000
    Problem solved!!
    (PHP version 5.3.12)

  4. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    very cool! Thanks for sharing that solution. I'll have to remember the idea of turning on error logging!

    Best wishes,
    Tobias

  5. rytrom
    Member
    Posted 2 years ago #

    Running a WP hosted solution. Don't see php.ini. Tried to change it in the wp-config.php file but with no luck. How to fix it?

    many thanks!

  6. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    changing this in the wp-config.php is not possible, as this is a PHP setting. From what I know, it can be changed with an .htaccess file, but in your case it might be the best to ask your webhost company to do it.

    Regards,
    Tobias

  7. rytrom
    Member
    Posted 2 years ago #

    ok. changed it in the htaccess file to 3000 - same result.

    how should i turn logging on to see the exact problem in my case?

  8. rytrom
    Member
    Posted 2 years ago #

    btw, I doubt it's this setting. forgot to mention that when i create a table first time it's loaded just fine but doesn't allow me any future savings. should have mentioned it before...

  9. j-prause
    Member
    Posted 2 years ago #

    I have described my solution in a post above, see here.
    If you have ftp access to your hosted WP, create a pure textfile named .user.ini containing just one line:
    max_input_vars = 2000
    or any value you wish.
    Using ftp, place this file into the root directory.
    For me this works.

  10. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    @rytrom: That still sounds like the problem. The issue is with the saving, not with the creation.

    @j-prause: Thanks for this! Let's hope it works fpr rytrom!
    If not, I suggest to try to find out of there's anything in the server's error logs (maybe with the help of the webhost company).

    Regards,
    Tobias

  11. rytrom
    Member
    Posted 2 years ago #

    i'm hosting with dreamhost. how to turn loggin on?

  12. j-prause
    Member
    Posted 2 years ago #

    @rytrom: I suggest that you first of all try this!

  13. Chad Warner
    Member
    Posted 2 years ago #

    I added max_input_vars = 2000 to the php.ini file in my public_html directory, and it worked. The problematic site is on a subdomain, so I first tried putting the php.ini in its subdirectory, but that didn't work. Thanks for the tip, j-prause!

  14. j-prause
    Member
    Posted 2 years ago #

    @Chad: use .user.ini as I suggested. See relevant chapter of PHP Manual.

  15. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    as it seems, both php.ini and .user.ini seem to work here. Great!

    Thanks a lot for your work on this, Chad and j-prause!

    Best wishes,
    Tobias

  16. deiseach
    Member
    Posted 2 years ago #

    j-prause, you have solved a problem that has bugged me (no pun intended) for two years! Thank you very much.

    Oh, and thank you to Tobias for a great plugin.

  17. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    great to hear that this fix also worked for you! :-)

    Regardless, you should consider migrating from WP-Table Reloaded to the official successor TablePress, which is not prone to this error, due to a different saving mechanism using AJAX.
    For more information, please see http://wordpress.org/extend/plugins/tablepress/ and http://tablepress.org/migration-from-wp-table-reloaded/

    Regards,
    Tobias

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP-Table Reloaded
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic