WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP-Table Reloaded] Caching option enabled by default

[Plugin: WP-Table Reloaded] Caching option enabled by default

  • kgagne
    Participant

    @kgagne

    Hi, Tobias โ€”

    Maybe this isn’t a bug but a feature ๐Ÿ™‚ but I’d like to request that, when a user installs the latest upgrade to this plugin, the new caching feature not be enabled by default.

    I have one table that I use in a dozen different places on my site, each one presenting different data through the filter shortcode. My site recently started producing a ton of 404 errors, which I found was due to each of these dozen instances of the table producing identical data! The links in 11 of them were broken, as they were not designed to be displayed on those pages.

    I upgrade my plugins without carefully noting the new features, so it took me awhile to discover that WP-Table Reloaded had a caching function that I’d never enabled. Once I disabled it, all was right with the world.

    Just one user’s experience โ€” YMMV. Still a great plugin!

    -Ken

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author TobiasBg
    Participant

    @tobiasbg

    Hi Ken,

    thanks for your feedback, I really appreciate hearing users’ experiences!

    The problem with caching and Extensions is definitely a serious one, as it can really have a severe effect on sites that use the plugin for tables.

    That’s however a problem with new features in general: There might always be something that speaks against activating them by default. In this case, it’s Extensions. Unfortunately, there’s no real way to detect whether an Extension is installed during the update, so I stuck with the default of activating that feature in all cases, the reason being that Extensions are not widely used and that they are kind of “bonus” material. (Compare this to WordPress itself: While there are new features added in every version, they don’t really have them deactivated by default, like with the new admin bar. If someone already used a plugin for that, the feature would break their sites as well.)

    So, while I’m not going to change this default behavior, I have learned for the future that such changes or new features that could have a severe impact on a site need to be communicated more actively. This does however also require more attention by users (no offense meant here), as from my website stats I know that the release announcement of the update is not read by many people, compared to the number of plugin downloads.

    Regards,
    Tobias

    kgagne
    Participant

    @kgagne

    Thanks, Tobias!

    FYI, I had this problem on another site that didn’t have the Filter Extension installed. In that case, I was displaying the table in one place with rows ABC hidden, and somewhere else with rows XYZ hidden.

    So though it’s not just a conflict with Extensions, you’re still right that I should’ve RTFM.

    -Ken

    Plugin Author TobiasBg
    Participant

    @tobiasbg

    Hi Ken,

    that’s a good point: I assume that you were hidding the columns differently using the Shortcode parameters?

    So, yes, you are right, it is not just with Extensions, but anything that dynamically alters table content, i.e. Shortcode parameters, Template Tag function arguments or Extensions (through plugin hooks and filters).

    About that “RTFM”: Well, there is no real “M” for this issue, yet, so you are not really to blame here. I guess I will need to find some time to write this down in good way. Not just mentioning the new feature and hoping that people might find out about the cause of their problems is not really enough.

    Best wishes,
    Tobias

    kgagne
    Participant

    @kgagne

    Tobias,

    Correct. One instance of the table was displayed with this code:

    [table id=1 hide_rows="2,3,4,5,6,7,8,9,10" hide_columns="6 /]

    Here is its other manifestation:

    [table id=1 hide_columns="4" hide_rows="11,12,13,14,15,16,17,18,19,20,21,22,23,24" /]

    After our recent discussion regarding other issues I had with these same tables, it took me awhile to realize that it wasn’t the same problem!

    Caching is still a neat option and one I’ve left enabled on many of my tables. It was these unique situations where I had to disable it.

    -Ken

    Plugin Author TobiasBg
    Participant

    @tobiasbg

    Hi Ken,

    yes, that’s one of those situations then where the caching is more or less breaking the Shortcode parameters, so you’ll need to disable the feature for that table.

    But it’s good that the feature is still useful for the other tables ๐Ÿ™‚

    Regards,
    Tobias

    Hi,

    I’m using wp-table-reloaded and may I know is there is any option to show different tables to different users? This for nothing but to display each employees work details in their own account.. Pls help me….

    Plugin Author TobiasBg
    Participant

    @tobiasbg

    Hi,

    something like that is not possible without extra programming.

    I suggest that you use a custom page template, where you make checks on which user is logged (through the available WordPress functions for this), and then display a certain table by using the WP-Table Reloaded template tag (instead of the Shortcode).

    Regards,
    Tobias

    Hai Thanks for your replay, Tobias….

    Let me try through that way…..

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: WP-Table Reloaded] Caching option enabled by default’ is closed to new replies.