Support » Plugins » [Plugin: WP-Table] Need a fix for 2.5 compatability

  • We use the heck out of this plugin and very much need it to work with 2.5. Has anyone gotten it fixed? As far as we can tell it’s only the activation process that doesn’t work correctly, the tables themselves show up fine if you don’t disable the plugin when upgrading.

Viewing 15 replies - 1 through 15 (of 26 total)
  • Anyone interested in a paying project on this?

    Hi there,
    I found that it was other plugins that were preventing WP-Table from activating. Try disabling all of your other plugins (it was Cforms for me), activate WP-Table first, and then re-enable all the other plugins. That seems to be working for me, everything appears to be OK.

    It works (in WP 2.5.1)! Thanks for the tip daltonrooney!

    I disabled the cforms plugin, and activated wp-table just fine. Then re-activated cforms without any problems.

    I’ve had the same issue. And believe it has to do with the fact the WP-Table doesn’t check if the buttonsnap class is already loaded (cform uses this one,too), cforms does however – that’s why the order of activation is important. someone should tell the author of WP-Table to fix it 🙂

    –regi

    I don’t know if this will help at all, but I also use the Embedded Video with Link plugin from jovelblog

    And if it really is this buttonsnap class that is causing an issue, a developer called ‘Michael Bester’ posted on the Embedded Video page and left a comment about solving this problem:

    Embedded Video

    which might be useful for WP-Table?

    Forgot to add the actual content (in case the site goes down)

    In your embedded-video.php on line 365, you have:

    require_once(”buttonsnap.php”);

    if you replace it with this:

    if( !class_exists(’buttonsnap’) )
    require_once(”buttonsnap.php”);

    Thanks. I had same problem and could’nt activate wp-table plugin in 2.5.1. Followed instructions above – deactivate cform, activate wp-table then reactivate wp-table. Perfect thanks

    Yes – deactivate all plugins, activate wp-table and then reactivate wp-table.

    In my case, it was digital-fingerprint (v0.2) which conflicted — and would not activate once wp-table was activated. It too just merrily used buttonsnap without checking first.

    By the way, I firstly tried editing wp-table to use mosey’s tip, above, but wp-table still crashed with fatal error.

    Does anyone know what the exact fix to wp-table.php should be?

    (Too bad the author doesn’t seem interested in fixing his very useful plugin!)

    ~Andrew~

    Thanks for testing out the idea, AndrewRH 🙂 I actually wasn’t sure if it would work or not, but it seems like it doesn’t (sadly) Maybe if people can post the details about the fatal error, that might be the way forward?

    I have to admit I haven’t experienced the same issues so far. Keeping my fingers crossed!

    I deactivated cForms and activated WP-Table and the table works again!

    I then tried activating cForms and received a Fatal Error.

    Reversed the process and then WP-Table received a Fatal Error.

    Has anyone been able to review the plugin code for WP-Table to make it compliant with the latest version of WordPress.

    Just realised the previous instructions don’t seem to make much sense:

    deactivate cform, activate wp-table then reactivate wp-table

    So
    1. De-activate cform
    2. Activate wp-table
    3. Re-activate wp-table (???!?????)

    Are people simply just de-activating then re-activating wp-table twice??

    Anyway, just an update on the code. I’ve re-read my previous post about the edit, and found that perhaps it was a bit misleading since I literally copy-pasted from the comment for Embed Video.

    I reproduced the ‘fatal error’ error on my 2.5.1 local install, and found it could be resolved by adding an edited version of the previous code. IE.

    Find Line 344 in wp-table.php which should be:

    require_once(WPTABLE_ABSPATH.'js/buttonsnap.php');

    and add before it:

    if( !class_exists('buttonsnap') )

    so you end up with:

    // ButtonSnap needs to be loaded outside the class in order to work right
    if( !class_exists('buttonsnap') )
    require_once(WPTABLE_ABSPATH.'js/buttonsnap.php');

    Hope this helps 🙂

    I can’t thank you enough, mosey!!

    Your fix (above) worked PERFECTLY and restored all the tables that I lost when I upgraded to WordPress 2.5, not realizing that this plugin would be incompatible. I am now using it — with your simple modification — and it is working with WordPress 2.6!!!

    Hooray!!

    You can see it back in action, for example, here:
    http://www.jhsiess.com/2007/12/24/christmas-carnival-family-life/

    THANKS AGAIN!

    flick

    (@mosey)

    @jhsesq: Glad to hear it’s working for you – esp in WP 2.6, as this is great news for me as well, so thank you for the feedback. 🙂

    Full credit goes to Michael Bester (see earlier post) who provided the fix for the Embedded video plugin; essentially it checks to see if another plugin is loading ‘button_snap’, and so it doesn’t load more than once.

    YikYak

    (@yikyak)

    Genius! Thanks ever so much.

    flick

    (@mosey)

    You’re welcome 🙂

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘[Plugin: WP-Table] Need a fix for 2.5 compatability’ is closed to new replies.