Support » Plugins and Hacks » [Resolved] [Plugin: WP-Syntax] Admin/General Settings page issues

[Resolved] [Plugin: WP-Syntax] Admin/General Settings page issues

  • I’ve just upgraded a WordPress install to 2.8 that uses the WP-Syntax plugin (version 0.9.6).

    When navigating to the General Settings page in the admin area, the page display was truncating at the Timezone setting – nothing in the Timezone dropdown and the rest of the settings on that page won’t display.

    I deactivated all plugins, then reactivated them, one at a time, to see if there was a conflict, and the page displayed correctly until I reactivated the WP Syntax plugin. Then the issue returned.

    Also, while on the General Settings page with the plugin activated, the open/close functionality of the admin menu sections does not work. Navigate to another page, and they work again.

    For now, I deactivated the plugin, made sure my general settings were correct, then reactivated it so that my blog posts display properly, but would like to see this conflict issue resolved.


Viewing 8 replies - 1 through 8 (of 8 total)
  • I am having the exact same problem. It was a fresh install without the WP-Syntax plugin. I tried deactivating and deleting all plugins but it didn’t fix it. Do you have a redirect loop when you go to your home page? I do.

    No, I don’t have a redirect loop. Other than this issue, everything else seems to be working properly.

    I’ve checked my error logs and am getting a PHP fatal error for the timezone functionality on the General Settings page with the WP-Syntax plugin enabled:

    [13-Jun-2009 06:16:41] PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /home/xxxxxx/public_html/wp-includes/functions.php(3233) : runtime-created function(2) : runtime-created function on line 1

    I have reuploaded the files in both the wp-admin and wp-includes folder to be sure that they are all there in case some didn’t get replaced during the upgrade, but the problem persists.

    Would love to get this resolved.

    MichaelH: Thanks for the links to the thread and Trac tickets. Sounds like a lot of folks are having very similar issues.

    I did finally track down the cause of my issue. After reviewing my error logs further, I noticed some database errors that occurred during the upgrade to 2.8. An email to the wp-testers list brought a response back from DD32 to look for a plugin using the cr_ prefix, as that was included in the error messages.

    That prefix belongs to the Comment Relish plugin. After deactivating that plugin, deleting it from the server, and manually removing all of its options from the wp_options table via phpMyAdmin, my General Settings page now functions properly.

    Not sure why the issue seemed tied to whether the WP-Syntax plugin was active or inactive, but my blog works fine now with it activated.

    So are you saying that deactivating that plugin was NOT enough to solve the problem? Meaning did you deactivate, still experienced the problem, then removed the options, then the Settings->General panel worked?

    That’s correct, deactivating the Comment Relish plugin was not enough to clear the problem. I had to manually remove that plugin’s options from the database before the General Settings page worked correctly again.

    I was using version 1.0 of the plugin – hadn’t upgraded it to the latest version as I wasn’t aware there was a new version until a couple days ago.

    I found it was in an instance of a cloud server that was using .NET as it’s primary technology, even though PHP was enabled. I switched PHP to the primary and BAM! Worked like a charm.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] [Plugin: WP-Syntax] Admin/General Settings page issues’ is closed to new replies.
Skip to toolbar