WordPress.org

Forums

WP Symposium
[resolved] Fatal error: Class 'JConfig' not fou (6 posts)

  1. samtajoshi
    Member
    Posted 2 years ago #

    I have intgegrate wordpress component in my joomla website.
    After installing wp-symposium plugin into it, I recieved the following fatal error:
    Fatal error: Class 'JConfig' not found in D:\wamp\www\jword\components\com_wordpress\wp\wp-config.php on line 25.

    If anybody can answer this, then please help.

    http://wordpress.org/extend/plugins/wp-symposium/

  2. simon.goodchild
    Member
    Plugin Author

    Posted 2 years ago #

    I'm sorry I don't have much experience of Joomla, what is line 25 trying to do?

  3. samtajoshi
    Member
    Posted 2 years ago #

    Line no 25 is defining an object of the JCOnfig class of joomla.

    $JOOMLA_CONFIG = new JConfig();

    $JOOMLA_CONFIG this is declared as a global variable, before this statement.

  4. simon.goodchild
    Member
    Plugin Author

    Posted 2 years ago #

    Hi samtajoshi, this is way out of my area of expertise, I've never used Joomla so not sure where I'd start.

    Sorry - I appreciate that this is not the answer you were hoping for, but compatibility of WP Symposium with Joomla, and integrating WordPress into Joomla, is just something I don't know about.

    :(

  5. simon.goodchild
    Member
    Plugin Author

    Posted 2 years ago #

    The only thing I can suggest is that to create a new JConfig() instance, that object needs to be defined somewhere and the file in which it is defined, included before line 25. But this is a total guess, as Joomla may be doing something clever to define it already by then.

    Sorry samtajoshi that I couldn't help more.

  6. samtajoshi
    Member
    Posted 2 years ago #

    k no issues...
    Anyways Thanks!!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Symposium
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic