WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP Supersized] Won't display photos in default directory

[Plugin: WP Supersized] Won't display photos in default directory

  • I installed wp-supersized 1.2.1 today on my WordPress site, but cannot get it to display the .jpg images in the wp-content/supersized-slides folder.

    I tried displaying a Flickr channel, and that worked.

    I also tried uninstalling the plugin and installing version 1.1, and it still wouldn’t display the images in the folder on my server.

    Do I need to name the images in a certain way for it to work?

    http://wordpress.org/extend/plugins/wp-supersized/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Benoit De Boeck

    @worldinmyeyes

    If you were using the Single image mode, this was indeed a bug that I have now fixed in the last update (v.1.2.2).
    Your images may have any name you want.

    I’m using the slideshow mode, and I can’t get my images to display in both slideshow or single mode. I’ve installed the 1.2.2 update, and nothing changed.

    I’m a pretty advanced user with regard to development, so I feel really dumb in that I can’t get this plugin up and running.

    Is there a step-by-step tutorial with screenshots or video that shows someone setting it up?

    Plugin Author Benoit De Boeck

    @worldinmyeyes

    I have noticed that I have forgotten to remove a few debug lines that I had added in my code for version 1.2.2. (fighting a bad case of flu does not help in having clear ideas…). They should have no influence on the working of the plugin but this could actually be helpful to understand what is going on:
    Open you web page and have a look at the source of the page. Within the ‘slides’ part of the Supersized plugin, you will see a list of variables displayed as comments. Please copy the content of the variables and arrays in there and send them to me (contact form on my website) or post it here. It will help me understand what could be the issue.

    Thanks for your help, Benoit, especially while you’re sick (get well soon!).

    Here’s the code

    slides :  [/* custom_dir =  - full_custom_dir = ./wp-content/ - full_default_dir = ./wp-content/supersized-slides/slidesforpage4 - content_url = http://test.sethpartridge.com/Wordpress-Seth/wp-content *//* full_dir = supersized-slides/slidesforpage4 - dir = ./wp-content/supersized-slides/slidesforpage4/ - thumbs_dir = ./wp-content/supersized-slides/slidesforpage4/thumbs/ - dirArray = Array
    (
    )
     */
    {image : 'http://buildinternet.s3.amazonaws.com/projects/supersized/3.1/slides/quietchaos-kitty.jpg', title : 'Quiet Chaos by Kitty Gallannaugh', url : 'http://www.nonsensesociety.com/2010/12/kitty-gallannaugh/'},
    {image : 'http://buildinternet.s3.amazonaws.com/projects/supersized/3.1/slides/wanderers-kitty.jpg', title : 'Wanderers by Kitty Gallannaugh', url : 'http://www.nonsensesociety.com/2010/12/kitty-gallannaugh/'}],

    I also pasted the lines of code below, as they contain the images that are being displayed.

    Plugin Author Benoit De Boeck

    @worldinmyeyes

    It looks like you have a strange WordPress installation 😉
    When I connect to http://test.sethpartridge.com/Wordpress-Seth/, I get a ‘page not found’ page with WP Supersized working without problem (2 images from your wp-content/supersized-slides/slidesforpage4/ directory). But when I try http://test.sethpartridge.com or any other page of your site, only the default Supersized images are displayed, as if the plugin was unable to find your images, although everything seems to be fine when looking at the source.
    I must say that I do not see immediatly a reason for this behaviour.
    It looks almost as if you have two installs of WordPress on your site. One at the top level and another one inside your WordPress-Seth directory. Is this possible ? Can you give me more details about your WordPress installation ? (send me details at ben [at] worldinmyeyes.be)
    The plugin finds the location of wp-content through the content_url() function, so if the constants WP_CONTENT_DIR or WP_CONTENT_URL in wp-config.php do not match the actual location of the folder, it cannot find it. This could be related also to the problem.

    Hello,
    Hope you are better now.
    I have the same problem here except the flu…
    wp-supersized version is 1.4
    wordpress version is 3.2.1
    Here is the link to see the default images in the background.
    http://www.foraudrey-morges.ch/site/

    And here is the code generated by the plugin (which would be a really awsome plugin i if could make it work.

    Do you know if you first have to create the folder supersized-slides and then activate the plugin?

    Thanks for your help!

    <!--
    	Supersized 3.2.6 - Fullscreen Background jQuery Plugin
    	www.buildinternet.com/project/supersized
    
    	By Sam Dunn / One Mighty Roar (www.onemightyroar.com)
    	Released under MIT License / GPL License
    
            Adapted for WordPress (WP Supersized 1.4) by Benoit De Boeck / World in my Eyes (www.worldinmyeyes.be)
    	-->
    
    		<script type="text/javascript">
    			jQuery(document).ready(function($) {
    				$.supersized({
    									slideshow               : 1,
    					autoplay		: 1,
                                    					start_slide             : 0,
                                    					random			: 0,
    					slide_interval          : 5000,
    					transition              : 1,
    					transition_speed	: 1000,
    					new_window		: 0,
    					pause_hover             : 0,
                                            stop_loop               : 0,
    					keyboard_nav            : 0,
    					performance		: 0,
    
                                    					image_protect		: 0,
    					image_path		: 'http://www.foraudrey-morges.ch/site/wp-content/plugins/wp-supersized/img/',
    					min_width		: 0,
    					min_height		: 0,
    					vertical_center         : 1,
    					horizontal_center       : 1,
                                            fit_always         	: 0,
    					fit_portrait         	: 1,
    					fit_landscape		: 0,
    									thumbnail_navigation    : 0,
                                            thumb_links             : 0,
    					slide_counter           : 0,
    					slide_captions          : 0,
                                    					slides                  :  [
    {image : 'http://buildinternet.s3.amazonaws.com/projects/supersized/3.1/slides/quietchaos-kitty.jpg', title : 'Quiet Chaos by Kitty Gallannaugh', url : 'http://www.nonsensesociety.com/2010/12/kitty-gallannaugh/'},
    {image : 'http://buildinternet.s3.amazonaws.com/projects/supersized/3.1/slides/wanderers-kitty.jpg', title : 'Wanderers by Kitty Gallannaugh', url : 'http://www.nonsensesociety.com/2010/12/kitty-gallannaugh/'}],
                                            slide_links             : 'blank',
                                            progress_bar		: 0,
    					mouse_scrub		: 0
    				});
    		    });

    hello again,
    I couldn’t wait because of work.
    I found another solution installing the supersized jquery plugin on the website.
    Unfortunately i had to add manually in the header the slides but i got it working.

    Later I’ll try again the plugin but in the meanwhile, it’s ok.
    in case you need inforamtions about what i did, just post a reply here and i’ll answer asap.

    thanks

    Plugin Author Benoit De Boeck

    @worldinmyeyes

    Now,
    I would need additional information to understand what is going wrong. In the options of WP Supersized, you could activate the debugging option and then send me (or post here) the variables contents that will then be present as comments in the slides list.

    For those of you who would want to use Supersized in your own themes and need more info on how to integrate Supersized (the original jQuery plugin) in WordPress, you can take a look at my tutorial on this subject. Although it has been written when still using Supersized 3.1.3, it is still valid with the newer versions.

    Plugin Author Benoit De Boeck

    @worldinmyeyes

    Now,
    I forgot to mention that I would really like to help you as I am a huge fan of Audrey Hepburn 🙂

    Hi benoit,

    I am also facing same problem. I have installed wordpress on my localhost also and online. My supersized slideshow for particular page exists here: http://www.redfiredesign.co.nz/redfiredigital/pal-work/
    I have created separate xml file for this page and xml file contains 3 slides.
    These images are visible in source code or thru firebug but images are not showing in slideshow when i try to click on navigation. You can still see the title for next image when i click on navigation.
    Can you plz guide me if I am missing something? or where is the problem? why slideshow is unable to load next image?

    Thanks,
    Baljit

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: WP Supersized] Won't display photos in default directory’ is closed to new replies.