WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP Supercache] Mod Rewrite rules cannot be updated!

[Plugin: WP Supercache] Mod Rewrite rules cannot be updated!

  • Hi,
    I have just installed wordpress on CentOS shared hosting (location: /www/wordpress/). I have downloaded and activated wp supercache but in ‘Advanced’ tab, it displays:

    You must have BEGIN and END markers in /.htaccess for the auto update to work. They look like this and surround the main WordPress mod_rewrite rules
    #BEGIN WordPress
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress
    Refresh this page when you have updated your .htaccess file.

    The problem is that the content of my .htaccess (location: /wordpress/.htaccess) is:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

    Where’s the problem? I’ve tried to comment the elseif that displays that error and plugin showed the code that i could paste into .htaccess. I have done it but supercache hasn’t recognized it.
    Can you help me? Thank you very much!
    Excuse me for the English, but I’m Italian 🙂

  • The topic ‘[Plugin: WP Supercache] Mod Rewrite rules cannot be updated!’ is closed to new replies.