WordPress.org

Forums

WP Super Edit
Code vice English appearing in MCE (7 posts)

  1. aethernavale
    Member
    Posted 4 years ago #

    I'm not sure when this started (should have been within the last month), and I know it has to be something not directing correctly, but deleting/reinstalling the plugin and the database options doesn't clear the issue and I don't know where to start looking from there.

    Example of the issue

    Shown is the search/replace feature, but it is the same with the Link menu as well. Same issue with both 2.3.7 and *.8.

    http://wordpress.org/extend/plugins/wp-super-edit/

  2. Jess Planck
    Member
    Plugin Author

    Posted 4 years ago #

    We've also discussed this issue a little bit here:

    http://wordpress.org/support/topic/plugin-wp-super-edit-advanced-link-dialog-white-screen

    I still need to go through an upgrade of some of the older TinyMCE plugins that are used. I basically take the plugins packaged with the developer version of TinyMCE and modify them to work from the wp-super-edit plugin folder.

    It's a little time consuming, but it may fix this issue.

    Now I do need some additional questions answered:

    Is this on a WordPress multi-site install?
    If so, Is this on a domain mapping site?
    Is this an english language site or is WP_LANG configured differently?
    Do you have other plugins installed that interact with the visual editor by adding buttons or features?

  3. aethernavale
    Member
    Posted 4 years ago #

    No, it is not a WPMU.

    No, it is not domain mapped. It was formerly hosted by my servers but I just recently moved the domain and hosting to Dream Host vice local due to connectivity issues with TWBC.

    English site, no configuration to language.

    There are no plugins installed that interact with the visual editor.

    Recent changes to the site configuration include:

    SSL to admin area (via config)
    Changing the wp-content directory name
    Specifically defining the following constants in wp-config:
    WP_HOME
    WP_SITEURL
    TEMPLATEPATH
    STYLESHEETPATH
    WP_CONTENT_DIR
    WP_CONTENT_URL
    WP_PLUGIN_DIR
    WP_PLUGIN_URL

    I can't think of any other major changes I've made that could possibly have affected it. The same plugins I have installed now (and I would even daresay the same versions of said plugins) were there before and everything was working fine.

  4. Jess Planck
    Member
    Plugin Author

    Posted 4 years ago #

    Okay, let's check the URLs that WP Super Edit should be loading. Open or create a new post where you can see those Search & Replace buttons in the editor.

    Do a view source and look toward the bottom for the searchreplace TinyMCE plugin URLs. It might look something like:

    tinyMCEPreInit.load_ext("http://something.com/wp-content/plugins/wp-super-edit/tinymce_plugins/searchreplace", "en");
    tinymce.PluginManager.load("searchreplace", "http://something.com/wp-content/plugins/wp-super-edit/tinymce_plugins/searchreplace/editor_plugin.js");

    You also mentioned that you moved this website. WP Super Edit might break when moving some older installs and might require you to reinstall the WP Super Edit tables for the database.

  5. aethernavale
    Member
    Posted 4 years ago #

    but deleting/reinstalling the plugin and the database options doesn't clear the issue and I don't know where to start looking from there.

    ^ Already did that.

    Also, the website data moved, but the addresses for everything didn't change. The site has always been parked at the same domain, the only difference is where DNS/Material was hosted from. Instead of using my local Windows servers I'm using a webhost to get around connectivity problems and so I could get more than a selfsigned SSL certificate. The local server domain was additionally changed from the original .net to .local to prevent DNS resolution conflicts on my end after the move was completed.

    The URLs you listed are currently annotated correctly for the site. It should be noted that menus like Anchor still work just fine, it is only the custom menus that do not.

  6. Jess Planck
    Member
    Plugin Author

    Posted 4 years ago #

    I've updated the included TinyMCE plugins to be close to the TinyMCE version in WordPress. Hopefully this will correct the translation issues.

  7. Elizabeth Powell
    Member
    Posted 3 years ago #

    I have the same symptoms, but I DO have a WordPress multi-site install with domain mapping. I'm running in the default English.

    Any solutions? I've made an attempt at looking for missing JS files and changed the domain in tiny_mce_popup.js, but to no avail.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Edit
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic