WP Super Edit
After update, SuperEdit not working... (14 posts)

  1. ramit
    Posted 5 years ago #

    Updated all my plugins, including SuperEdit .

    (Great plugin btw.)..

    Updated WP to 3.1, and now my visual edit menus are gone and the edit window shows nothing (well seems the letters are white on white background).. till I click on "HTML", then I see the html code for the content.

    I tried disabling SE , and then Activating it, also changing settings and updating... short of removing it from my WP .....

    When SE is disabled, I get my basic visual WP tool bars back.

    I have 5 sites, all are doing it, 3 different themes...
    Same hosting, some different servers.

    using FF 3.6.13

    Reading you bug report, tried toggling the visual editor under user profile, it wasn't checked, checked it, lost the visual editor as expected, went back removed the check, got the visual editor back, but still just a clear edit window, no tool bar.

    so far the only thing that "fixed" it and I get back the visual editor tool bar and content in the edit window is by disabling SE.



  2. lilatovcocktail
    Posted 5 years ago #

    I've got the same problem. I think it started with the last WP update to 3.1. And since the site with the SE problem has about 60 plugins, I'm dreading the process of looking for plugin conflicts. Anyone else with the same problem or any information about new plugin conflicts?

  3. ramit
    Posted 5 years ago #

    I've played around with this, and it turns out I had to go into the WPSE's set up and turned off (unchecked) "TinyMCE 2.x Compatiblity" and I got WPSE back and working on all my sites.

  4. lilatovcocktail
    Posted 5 years ago #

    No kidding. Thanks for sharing -- I'll go try it now.

  5. ramit
    Posted 5 years ago #

    no kidding, I was thrilled , so then finally spent the time to make all my WPSE edit icon bars look the same.. LOL - got tired of them all being different...

    let me know if it worked for you.... not that I know what else to try.
    Just good info for everyone else and the developer I guess.

  6. dbarch
    Posted 5 years ago #

    I'm having this same problem. Editor buttons not showing up with or without having TinyMCE 2.x compatibility turned off. Anyone have luck with something else? Thanks.

  7. ramit
    Posted 5 years ago #

    just a shot in the dark, I don't know why....

    Have you tried turning off super cache?
    The try to enable and then disable TinyMCE 2.X comp?

    I've had the strangest issues with super cache.

  8. Jess Planck
    Plugin Author

    Posted 5 years ago #

    So far the only issues I have that I can reproduce are:

    • Turn off TinyMCE 2.x compatibility plugin.
    • Some problems with translations on multi-site configurations.
    • Some older configurations may need to have the database files reinstalled.

    This version of WP Super Edit has been tested on WordPress 3.1 and I may have introduced some issues affecting older versions of WordPress. If so you may want to check the "Other Versions" and downgrade to an older version.


    I'm also interested to see if this is a PHP4 issue.

    So, I would appreciate if you can use a tool like Firebug to check for javascript errors. Also check the source in your edit post / page screen and check for any unusual includes or errors for other plugins. I am often seeing other plugins introduce errors. There are some older plugins that were introduced to work with WP Super Edit, but I don't think they have been upgraded.

    Javascript issues can be found on the post / page edit screen either between the <head> tag or before the closing <body> tag. You will find the primary controlling javascript for the editor associated with the tinyMCEPreInit values present toward the end of the html before the closing body tag.

  9. Jess Planck
    Plugin Author

    Posted 5 years ago #

    I was finally able to reproduce an issue causing the editor to malfunction on older websites using WP Super Edit.

    I couple versions ago I moved the "Custom CSS Classes" and "Super Emoticons" from being just "TinyMCE" plugins to being separate "WordPress Plugins". This was done because those two (and other personal ones) have functionality that requires more access to the WordPress internals, so they have to be activated as separate WordPress plugins.

    This fixed an issue dealing with callback functions that I shouldn't have been doing in the first place. Unfortunately it looks like it broke some sites that may have had these active for a long time.

    The easiest solution is to reload WP Super Edit.

    1. Make a note of the Editor Plugins activated and the position of the buttons for your editor.
    2. Go to the WP Super Edit Options tab and press the Uninstall WP Super Edit Database Tables button. This will remove the tables for WP Super Edit from your database.
    3. Go to the WordPress plugins area and make sure that WP Super Edit is the only active plugin. If the Theme Classes or Emoticon plugins are active, deactivate them.
    4. Go back to the Settings > WP Super Edit area and press the Install WP Super Edit button.
    5. If you want to use the WP Super Edit Theme Classes or Emoticon plugins, go back to the WordPress plugin area and activate those plugins.

    Unfortunately this will clear out all settings for the buttons and plugins that you may have had previously. You have my sincerest apologies.

    If you are brave, before you do any of this do a backup of the wp_super_edit_users table in your database. That table stores the actual button configurations, so you may be able to replace that table AFTER the reinstall and get some of your user's configurations working as before. I haven't tested this, but it should work.

  10. dbarch
    Posted 5 years ago #

    I think the previous comment probably applied in my case. I removed the WP Super Edit plugin and installed it again from scratch. Seems to be working fine now.

  11. Emily
    Posted 5 years ago #

    Instructions from ev3rywh3re worked for me! Thank you very much.

  12. lilatovcocktail
    Posted 5 years ago #

    Ah, yes, removing and reinstalling WP SuperEdit worked for me too. Which was good, because in the meantime I've been using a TinyMCE plugin which wasn't really very tiny and so was quite slow to load.

    Thanks for making and supporting WP SuperEdit!

  13. bcolwin
    Posted 5 years ago #

    Thanks so much, ramit. Your suggestion got it working again!

  14. ramit
    Posted 5 years ago #

    your welcome!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Edit
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic