WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP-Super-Cache,WP-Touch-Pro] White Page - Caching Stylesheet (15 posts)

  1. mattla93
    Member
    Posted 3 years ago #

    Hello,

    I noticed that WP-Supercache caches a WP-TOUCH PRO file called like this /?classic_include_dynamic=1&version=6c1f97d67fec3e255c0cb2279cc943de. The cached version has some errors, what causes a not fully loaded Stylesheet for wptouch. The Page is white and hasn't the normal background, ect.

    The Debug Log says this: http://pastie.org/pastes/3029950/text?key=mbwk7fxbdprehv8fbhf5xg

    I don't know why this get cached, because of the QUERY String, when I call the page again, this won't be cached. Maybe there is an user-Agent which isn't redirected to wp-supercache?

    PS: For the Test I used a Device, what has any cookies, and I cleared the cache before calling the page.

  2. BraveNewCode Inc.
    Member
    Posted 3 years ago #

    Hi Mattla,

    You'll need to add WPtouch's default user agents to the 'rejected user agents' area in WP Super Cache, then empty WP Super Cache's cache.

  3. mattla93
    Member
    Posted 3 years ago #

    This solution will solve the problem for sure, but I don't want to bypass the cache for mobile User Agents, because of the high load produced by the Mobile UA.

    Isn't there another solution?

  4. Donncha O Caoimh
    Member
    Posted 3 years ago #

    Those files aren't cached according to that log - "No closing html tag. Not caching."

    Is there anything in your PHP error log?

  5. mattla93
    Member
    Posted 3 years ago #

    Did you also read this lines:

    06:03:03 /?classic_include_dynamic=1&version=6c1f97d67fec3e255c0cb2279cc943de wp-cache file exists: /srv/www/page/wp-content/cache/wp-cache-c5b5692502dc8acea6c33b844e13a737.html
    06:03:03 /?classic_include_dynamic=1&version=6c1f97d67fec3e255c0cb2279cc943de Serving wp-cache static file
    06:03:03 /?classic_include_dynamic=1&version=6c1f97d67fec3e255c0cb2279cc943de exit request

    This means that this script was cached and served to a anonymous supercache user. Then after I deleted the wp-cache html Page the classic_include_dynamic File won't be cached again. Then after a while I've the same problem again.

    In fact this file is beeing cached, but it shouldn't. This problem I have on 4 Blogs where is installed wptouchpro and wp-super-cache. I wasn't able to figure out when this file exactly gets cached, because while testing the DEBUG reported that the file won't be cached because of the no closing html tag.

    Maybe there is a bug, that also files with closing html tags will be cached?
    But then also when this test fails the file shouldn't be cached because of the query string, am I right?

  6. mattla93
    Member
    Posted 3 years ago #

    I figured out the issue: The wpsupercache Plugin caches User Agents what aren't catched by the wptouch-pro Plugin, because the mobile User Agents of wpsupercache aren't the same as the User Agents in wptouch pro.

    So to a mobile user Agent from the wpsupercacheplugin what isn't catched from the wptouchpro plugin gets displayed the mobile page, and calls the /?classic_include_dynamic=1 File what is now a normal call to the Home Page with some GET Parameters, so this gets cached and the Cached home Version is loaded as a stylesheet for real mobile user agents. So these CSS styles are missing.

    To fix this I have some questions:
    1) There is a field in the settings: Add here strings (not a filename) that forces a page not to be cached.. Can I add here the line ?classic_include_dynamic=1 that there wouldn't be cached requests like
    /?classic_include_dynamic=1&version=6c1f97d67fec3e255c0cb2279cc943de
    Am I right?

    2) Is it possible to add a field where we can put the mobile User Agents cached with a seperate cache (in my case I would put the same in it as the wptouchpro User Agents, so this Problem above also is solved).

  7. BraveNewCode Inc.
    Member
    Posted 3 years ago #

    Hi mattla,

    1. We advice adding WPtouch's default user agents (you can find the list in the WPtouch admin panel) to the "rejected user agents" in WP Super Cache. This will ensure that the devices that see WPtouch will not get cached files and files that they see will not be cached.

    2. I don't believe that is currently supported in WP Super Cache, though what I proposed above should resolve the issue.

  8. Joe Siegler
    Member
    Posted 3 years ago #

    I just ran into a problem - the white screen in WP Super Cache.

    I had turned on mobile support in Super cache for WPTouch. But I had neglected to put the mobile agents in the rejected agents area. Now I'm getting a white screen. Don't know if it makes a difference.

    I don't know how to stop it and let me back in so I can fix it. I really do NOT want to uninstall and reinstall - and have to rebuild the cache, as I have several hundred pages - and I JUST now launched the site.

    I'm using the current Pro version of WPTouch, as well as the current "dev" version of WP Super Cache.

    Would really like a way out of the white screen without having to uninstall.

  9. Donncha O Caoimh
    Member
    Posted 3 years ago #

    Check your PHP error log as that's a PHP error. Rename the wp-content/plugins/wp-super-cache/ folder and that will disable caching, or do the same with the WPtouch folder. What PHP error do you see in your log?

  10. Joe Siegler
    Member
    Posted 3 years ago #

    I already disabled the WPTouch plugin. It didn't help the white screen.

    I'll look at the php log in the morning. For right now, the cache works, I just can't configure it.

    I turned off WPTouch for now, as it's 3:10AM, and I've been sitting here for about 12 hours. I need to sleep. I'll fix it tomorrow. :)

    Strange that it happened when I turned on the mobile plugin in WP Cache.

  11. Donncha O Caoimh
    Member
    Posted 3 years ago #

    Joe - I just remembered, I think there might be something in WPTouch Pro causing that error. I need to talk to the author of that plugin to find out why as I don't have the pro version.

  12. Joe Siegler
    Member
    Posted 3 years ago #

    Is there any way to edit the config parameters via a text file on the HD or something? There's one or two things I want to change, but unless I can get around the "white screen", there's no way for me to change anything.

    I also cannot turn off the cache, my server will crash and burn. Traffic levels are too high.

  13. Joe Siegler
    Member
    Posted 3 years ago #

    NOTE: I've uninstalled and removed WPTouch from my server, and the problem continues to exist.

  14. Joe Siegler
    Member
    Posted 3 years ago #

    Managed to get it unstuck. Well, my server guy did. He looked at it, and got me back into the Super Cache config area, removing the white screen. Here's what he said he did:

    wp-content/plugins/wp-super-cache/plugins/wptouch.php still existed though you had uninstalled it. I removed it. The issue that script was having was that it makes reference to a function named bnc_wptouch_get_exclude_user_agents() which doesnt exist

  15. Donncha O Caoimh
    Member
    Posted 3 years ago #

    Argh, I had a check in the code for that but forgot to check it in. The development version will update in the next 20 minutes and wptouch support won't cause that white screen. Sorry.

Topic Closed

This topic has been closed to new replies.

About this Topic