WP Super Cache
[resolved] Yet another page do not match, fetching anonymously through TOR confirms (5 posts)

  1. Lolc
    Posted 4 years ago #

    Page timestamps are indeed changing, which suggests cache is broken. The box is running nginx (with Supercache config from Donncha's relevant blog post), but switching to legacy caching does not fix the issue.

    Logs are as follows

    page is here http://tenebrix.org/

    Donncha, would you kindly advise as to where should I start looking?

  2. Lolc
    Posted 4 years ago #

    Okay, diagnosed and fixed it myself (at least works through PHP, rewrites still pending, but at this point it is a minor concern)

    Solution is basically this http://dentedreality.com.au/2008/09/wp-super-cache-not-creating-meta-files/

    Stuff <?php while (ob_end_flush()) {} ?> at the veeery bottom of theme's footed.

  3. Lolc
    Posted 4 years ago #

    Resolved, I'd say.

    Just a quick summary for search engines:

    Did not write meta file: wp-cache-somethingorother

    start showing up, it might be worthwhile to try stuffing <?php while (ob_end_flush()) {} ?> at the very end of your theme's footer.

  4. Donncha O Caoimh
    Plugin Author

    Posted 3 years ago #

    Wow, that's a head wrecker. I wonder if there's a place for putting that while loop in the plugin if it isn't caching correctly? It could then "fix" broken plugins.

    Unfortunately it might not either because the broken plugin might do something odd with the buffer..

  5. Martijnchel
    Posted 3 years ago #

    is there another solution for this problem?
    The only thing that's wrong when looking at the debug is that it does not write meta files. The meta folder is empty.
    I added that function at the bottom of my footer.php but no luck. Still the same problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic