Support » Plugins » [Plugin: WP Super Cache] expired pages not deleting

  • hey,
    i have upgraded WP Super Cache to latest version on my fairly popular blog few days ago and i seem to have some issues with the new version: it works well, but although i have set the garbage collector to 1 hour, it removes only WP-Cache files, but not WP-Super Cache files, which remain there even though they are expired. visitors are not updated with the latest content as the result. someone got any ideas?

Viewing 15 replies - 1 through 15 (of 22 total)
  • You could try adding error_log() calls to the prune_super_cache() function – log the parameters, and you should also log what files are deleted.

    See the manual page for how to use that: http://uk3.php.net/error_log

    i rather moved back to 0.6.8 which seems to work fine…

    Same problem here on 2.3.3. It will not take out the garbage, no matter what deletion setting I choose. I’ve even gone so far as to set the entire cache directory to 777. But I know the plugin can write to the directories because it’s making new cache entries all the time. And on mine, it won’t delete standard WP-Cache files either. So they all just pile up. What’s worse is Super Cache will just serve up the old files no matter what I set the expiration time to. It requires me to manually empty the cache. Thoughts?

    I should add that I’ve already tried the suggestion above about error logging the prune_super_cache() function. I set it to email me. And the only time it does is when I either empty the cache myself or I deactivate the plugin. In other words, the pruning function isn’t running unless I made it run. I know the plugin is using WP’s cron API, but for some reason, it doesn’t seem to be working.

    Incidentally, I tried White Shadow’s Cache Cleaner plugin, the code from which you had rolled into the latest version (0.8.4), and it works just as advertised. Unfortunately, Cache Cleaner only cleans out the Super Cache and not WP-Cache entries.

    Its stuck here and cannot get those 1183 expired pages to go away no matter what. Problem with latest version only. The earlier one was fine.

    WP-Cache
    * 0 cached pages
    * 0 expired pages
    WP-Super-Cache
    * 0 cached pages
    * 1183 expired pages.

    pchere – look in your wp-content/cache directory, are the files writable by the webserver?

    Its 755

    Even tried 777, but of no use.

    I reinstalled the previous version .0.8.3 and it is ok now. But the version in the plugin dash still shows 0.8.4

    I switched back till an update is available.

    I have the same issue

    have had this message in the settings for ages, and it usually displays posts that are a few weeks old.

    Cache Contents

    WP-Cache

    * 0 cached pages
    * 0 expired pages

    WP-Super-Cache

    * 0 cached pages
    * 12 expired pages.

    I will try reverting to a previous version.

    Hope there’s a fix soon!

    punkelstein – Can you check if your supercache directory has files with multiple \ characters? pchere’s article above mentions that. It would be great if you could find the requests that created those files.

    I think I’ve found the problem. unlink/rmdir were being passed arguments that were addslashed. Removing the addslashes() seems to have fixed it.

    Hey,

    I have the same issue (I’m running version 0.8.5 on wordpress 2.6.5)

    The cache folder grows rapidly eating up my quota and the expired pages are not deleted . I have tried all the above tips as well as different configurations but the numbers of expired pages are still growing. It seems to me that the garbage collector doesn’t work for some reason. Unfortunately, I had to disable the plugin until there is a solution.

    Any help will be appreciated.

    Thanks in advance.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: WP Super Cache] expired pages not deleting’ is closed to new replies.