[Plugin: WP Super Cache] WP-Super-Cache DOES NOT work with 2.7! (52 posts)

  1. Paleo Pat
    Posted 7 years ago #

    I am writing this to give everyone a heads up. WP-SUPER-CACHE does NOT, I repeat, DOES NOT WORK with verson 2.7. Sometime during the development stages of 2.7. WP-Super-Cache stopped functioning. I notified the author, and he WANTED ME to "Debug" the bloody thing. Which is impossible, because for starters, I know zero about debugging or programming, not to mention, I am on shared hosting and have no access to Apache logs. My Blog is on site5.com's servers, which piggy back on The Planet's servers.

    It just will not cache pages, like it was doing. It will install, but if you turn it on, it does not cache at all. it changes your .htaccess like it is supposed to, But no cache at all. I even tried turning off compression the numbers stay at zero.

    Just letting everyone know, before the heartache begins.


  2. Donncha O Caoimh
    Posted 7 years ago #

    Thanks for the reminder Pat, your original comment never mentioned WP 2.7, and was left on my blog at 6.25pm on a Saturday evening. Hardly the best time of the week to look for unpaid support of Free Software.

    Your reaction on Twitter on Sunday didn't really help however. Slight overreaction? (Warning! NSFW text)

    Anyway, to put your mind at ease, the plugin will be updated and will work with WP 2.7 before it's released.

  3. Erunafailaro
    Posted 7 years ago #

    Hi all,

    I would like to add, that I am currently using WordPress 2.7-RC1 and there are no problems with WP Super Cache. All cached pages contain these comments:

    <!-- Dynamic Page Served (once) in 2,015 seconds -->
    <!-- Cached page served by WP-Super-Cache -->
    <!-- Compression = gzip -->

    So what exactly is the problem?

  4. Donncha O Caoimh
    Posted 7 years ago #

    I've just verified that WP Super Cache works with the latest WP 2.7 code out of SVN. It's running on http://notspam.org/ just fine.

    I think there's something else wrong, either something in PHP5 or some local configuration issue. If anyone is seeing this same issue (no cache files being created in the supercache directory), please send login details to your server to donncha @ gmail.com and I'll investigate.

    I'm off to try PHP5.

  5. Donncha O Caoimh
    Posted 7 years ago #

    PHP5 works fine too. Pages are cached, and static files are served to anonymous users.

  6. Donncha O Caoimh
    Posted 7 years ago #

    And it works fine with fastcgi too. I wonder if it's an suexec problem?

  7. Michael Torbert
    WordPress Virtuoso
    Posted 7 years ago #


    For what it's worth, it doesn't work for me on 2.7B3 or RC1 either. If you'd like me to assist you with debugging, feel free to contact me and I'll be happy to help in any way I can.
    Thank you for the time you've spent working on this free plugin. It's one of the top several plugins for WordPress.

  8. KirkM
    Posted 7 years ago #

    I'm on a Bluehost shared server and Super Cache was working fine with all previous versions of WP back into the 2.5 series all the way through the 2.7 trunk builds until a few days ago when the cached pages stopped being served altogether. Nothing changed on my server with the exception of the MySQL database being upgraded from 5.0.45-community to 5.0.67-community and I really don't think that was the problem.

    I've been running PHP 5.2.6 (fastcgi) with no problem either until the last few trunk builds (via the "Stay Updated" link) prior to RC1 when the plugin simply stopped working. At RC1, I enabled "compression" on Super Cache's settings page and the plugin started working again. This makes no sense to me.

    Yesterday, I upgraded a client's site from 2.6.3 to 2.6.5 and Super Cache simply stopped working for her as well and enabling compression, uninstalling and reinstalling Super Cache, re-entering the .htaccess rules had no effect. I just left the plugin activated and logged out since her site was still loading fast enough (.55* average). She's running the same MySQL and PHP versions as I am on a different Bluehost server entirely.

    Just on a whim I checked her site's source code this morning and there was the Super Cache entry at the bottom just like it should be and just like it wasn't the day before. Nothing changed at all overnight.

    No errors in the error logs. No errors in the Apache logs. Nothing to give me a clue as to what went wrong. Paleo Pat and the others who had problems do not run on Bluehost that I know of and most likely have different set ups then myself and my client. Some folks are having problems and some are not (all running either 2.6.5 or 2.7 trunk or RC1)

    Ghost in the machine?

    And many thanks for this most excellent plugin. Us shared server bloggers would be lost without it.

  9. Donncha O Caoimh
    Posted 7 years ago #

    hallsofmontezuma and KirkM - Can you download the updated scripts from here and copy into plugins/wp-super-cache/ ?

    I've changed the plugin so it uses uniqid() instead of tempnam() which is the only reason I can think of for the cache to stop working as that change was added in 0.8.5.
    Was it after you upgraded to the latest version that the problems started?

  10. It's working for me on my site. Absolute latest 2.7 SVN, I just updated.

  11. Jeremy Clark
    Posted 7 years ago #

    Working fine for me as well.
    php 5.2.6
    mysql 4.1.20

  12. KirkM
    Posted 7 years ago #

    Was it after you upgraded to the latest version that the problems started?

    It seems so, at least in my case. The funny thing was that I had two sites both running the same versions of 2.7, upgraded at the same time (nightly builds) and the only thing that changed the day Super Cache stopped working was updating to Super Cache 0.8.5 from 0.8.4

    Strangely enough, 0.8.5 was working fine all morning on both sites (then at RC1 beta3-almost RC1-almost), I went to lunch, came back, checked the sites, and both sites were no longer being cached. The next morning, both sites were being cached but no more than an hour later--no caching. Upgrading to 0.8.5 was all that changed over that period of time.

    Currently, only the site running WP 2.6.5 is not being cached. The other two 2.7 RC1 sites are currently being cached properly with 0.8.5 (go figure).

    Oh yeah, I see that 0.8.6 has been released. I'll give it a try. I've got 3 sites that are running 2.7 RC1 to test it out on. .htaccess Rules can stay the same I'm assuming?

    Sorry for the long replies. I have a bad habit of being too wordy.

  13. Donncha O Caoimh
    Posted 7 years ago #

    Check your wp-config.php before you upgrade. Is there a "define( 'WP_CACHE', true );" in there?

    The check for that was modified in the last month to handle whitespace in front of the define() and also to handle when that constant is defined elsewhere. I didn't do the "pre existing" check properly.
    I presume that after you upgraded you may have disabled the plugin and then reenabled, or turned off caching and then on again and the WP_CACHE define was removed or commented out.

    Anyway, hopefully upgrading to 0.8.6 will solve the problem. It's not a mysterious WordPress 2.7 issue!

  14. KirkM
    Posted 7 years ago #

    I tend to agree after working with the problem that it's not a WP 2.7 problem specifically.

    Just by long habit I checked my "wp-config.php" file for "define( 'WP_CACHE', true );" while experiencing the problem and it was there. Now that I think about it, I regularly turn off caching if I'm working on the sidebar content or other items that need caching to be off while viewing any changes made. I've always been able to turn caching back on and have it just start working successfully without having to check "wp-config.php" for the entry.

    Super Cache has always been well behaved in the past. Turn it on/turn it off/deactivate it/reactivate it...no problems. Pretty amazing considering what it does (nice job that one).

  15. Paleo Pat
    Posted 7 years ago #

    Well, I installed the new version. Still not working, at all.

    Here's what my host runs:

    Operating system Linux
    Kernel version 2.6.9-67.0.22.ELsmp
    Machine Type i686
    Apache version 2.2.9 (Unix)
    PERL version 5.8.8
    Path to PERL /usr/bin/perl
    Path to sendmail /usr/sbin/sendmail
    PHP version 5.2.5
    MySQL version 5.0.51a-community-log
    cPanel Build 11.23.6-STABLE 27698
    Theme cPanel X v2.6.0
    Documentation Click to View
    cPanel Pro 1.0 (RC1)

    All I know is, that it was working. and sometime during the development process, it stopped working, totally.

    If Donncha wants to be a serious programmer and a real man, and possibly see why it is not working, I'll work with him. But if he wants to be your a-typical programmer and blame the user, he can have a nice day.

    Sorry, the stupid "it's free software" argument doesn't fly with me. You provide a service and if you're not a big enough man to back that service up, you should withdraw it for the market.

    Just that simple.


  16. Donncha O Caoimh
    Posted 7 years ago #

    Pat - check the Troubleshooting section of the readme.txt, something in that list may help.

  17. Jeremy Clark
    Posted 7 years ago #

    Pat the personal attacks are very immature and if they continue you will be blocked. Also being polite will always get you more answers.

  18. Michael Torbert
    WordPress Virtuoso
    Posted 7 years ago #

    It's not in "the market". It's free software. Donncha spends a lot of time making this free software, and took time off from his day yesterday to debug it with me. You don't have a right to the software, or to free support. I'd recommend being much more polite in the future if you want assistance.
    He doesn't provide a service. That absolutely incorrect. He wrote a plugin and allows others to use it for free. He doesn't owe and free support, so you should appreciate that he provides it at all, rather than demanding it on your terms.

  19. Erunafailaro
    Posted 7 years ago #

    I have to agree with hallsofmontezuma.

    If anyone is unsatisfied with this plugin or with Donncha's help (which, I think is hardly possible) then he or she has the freedom to uninstall WP-Super-Cache.

  20. Michael Torbert
    WordPress Virtuoso
    Posted 7 years ago #

    Good idea Erunafailaro, or for that matter WordPress, and any other free software. WordPress doesn't offer free support either. Why don't you try contacting a WordPress core developer and see if they will help you out when you have a problem?
    WordPress has had more than its fair share of times when things didn't work well. Go ahead and tell Matt that he needs to be a "serious programmer and a real man", and offer free support for you when you can't get something working on his free software.

  21. Paleo Pat
    Posted 7 years ago #

    *Waving White Flag!*

    Okay, I checked that list. and so far everything checks out. I installed, again. Checked the permissions and settings.

    I turned the ol' Girl on and this is what I got:


    * 0 cached pages
    * 0 expired pages


    * 2 cached pages
    * 0 expired pages.

    She cached two pages and then quit. I've checked again.. and she only did two pages. is there something that I'm missing here?

    I love the Plug-in, I just wanna get it to work. :)

  22. Paleo Pat
    Posted 7 years ago #

    I think I may found a bug... Wow!

    Okay, looking in the / public_html / wp-content / cache / directory... I'm seeing the files.. so, Super and normal cache is working.

    But the number reporting dept is not. It's showing the number of super cached files, but the normal one's ain't being counted. They're working, but the problem is that the Plug-in ain't displaying the number of files cached. (Normal cache, not super, super is working, I'm not sure about the expiring part.

    The reason I thought the plug in was broken, is because the numbers we're not displaying like they were.

    I knew it had to be something. I'll let you know if the number of the expired cache are working or not. But your normal cache number reporting system ain't working... at least on this server.

    Don't ask me man, I just report what I see. :)


  23. Paleo Pat
    Posted 7 years ago #

    Okay, this Plug-in is making me look REEEEEEALY Stupid man.

    The Cache section is working.... Just not like it was before.

    I think it might have something to do with you adding that temp directory or file feature in the last major release.

    It's counting it, just not nearly as fast as before. AND, the super starts counting before the normal cache does. Didn't do this BEFORE.

    All the yelling and acting a darned fool for no reason at all. I will be sending an apology via twitter as well.

  24. pinkflozd
    Posted 7 years ago #

    Stopped working for me too after upgrade from 2.6.5 to 2.7-RC1-10073
    No pages are getting cached or served cached

  25. michael.aulia
    Posted 7 years ago #

    Working fine here on 2.7 RC1 @my blog

    and thank goodness that you are apologizing. Donncha is a great guy and like others said, it's free and he spends all day and night to give us this wonderful plug-in and here we are complaining! :)

    Back to topic, err yeah it's working fine here (but I'm still 0.8.4 though, not the latest one, which is 0.8.6)

  26. Donncha O Caoimh
    Posted 7 years ago #

    pinkflozd - checked the trouble shooting section of the readme and verified it's none of those issues?

  27. tommy_peoplejar
    Posted 7 years ago #

    i have wp 2.7 rc1 on our company blog with the wp super cache 0.8.6 working fine as well.

    <!-- Dynamic Page Served (once) in 0.110 seconds -->
    <!-- Cached page generated by WP-Super-Cache on 2008-12-08 17:56:05 -->

    btw, if you are using nginx rather than apache, this article at slicehost has a nginx conf section

  28. pinkflozd
    Posted 7 years ago #

    yes i tried all possible tricks...tried also completely deleting it and deleting all entries ... then reinstalled all files get created, define( 'WP_CACHE', true ); is there ... the trick is that i use lighttpd, but it worked flawlessly since wp 2.5 -> 2.6.5 ... did you changed the rewrite rules?

    by the way thanks for this magnificent server saver

    Edit: Tried with apache ... doesn't work either

  29. cadbloke
    Posted 7 years ago #

    Works fine on my site.
    WordPress 2.7-RC1-10119
    PHP 5.2.6
    Hybrid Theme - Old School child theme
    MySQL 5.0.67
    Only other plugin is Akismet.

    I have used this on a few different sites - any (rare) problems have been plugin-related. I was trying to break the (test) site at the time so I knew it was my fault.

    dooncha - love your work. Thanks!

  30. Donncha O Caoimh
    Posted 7 years ago #

    pinkflozd - can you email me at donncha @ ocaoimh.ie and send me login details for your server? Maybe I can debug it and figure out why it's messed up.

Topic Closed

This topic has been closed to new replies.

About this Topic