Support » Plugin: WP Super Cache » [Plugin: WP Super Cache] Reword "Only refresh current page when comments made"

  • I’ve been using WP Super Cache for months, but only today have I finally figured out what this option does. The wording for it, although grammatically correct, is unidiomatic and therefore confusing to native English speakers. In particular, the placement of the word “only” in front of the verb gives the wrong impression of what is happening. Moreover, using the term “current page” makes it sound like it’s the most recent post being updated (or not), rather than the home page. I have unchecked this box repeatedly over the past few months, only to find out to my dismay that my home page was not updating when new articles were posted.

    I cordially recommend changing the wording to “Refresh home page only when comments are made” to alleviate some of the confusion.

    However, given the fact that this is in fact exactly the opposite of what really happens (when the box is checked, the home page is not updated by comments), I think the wording should actually be “Refresh home page only when new post or page is published.” Then there would be no confusion.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Donncha O Caoimh


    It’s “Only refresh current page when comments made.” which I admit is terse but when enabled the plugin should only delete the cache for the page where the comment was made. (I think there’s a bug in there somewhere, in some situations, where some archived pages are also deleted unfortunately but that’s another story)

    I’ll consider this for the next version.

    Why donncha call the option:

    “Delete the cache only for the page where the comment was made”

    just like you wrote above. I think it’s much more clear than talking about a “current page” (which lead the fellow user think you are referring to the Home page) or mention “refresh” (delete cache is less mysterious) and it’s clear the adjective “only” refers to the page where the comment was made rather than applying it to “refresh current page” which is very confusing.

    BTW, the cron that’s supposed to trigger the Preload Cache is not working on my install (WP v3.5 with Nginx) and even when I manually do it by pressing “Preload Cache Now” after a while all pages are deleted for no reason (cron job does not work).


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: WP Super Cache] Reword "Only refresh current page when comments made"’ is closed to new replies.