Support » Plugins » [Plugin: WP Super Cache] very frequent “403 Forbidden” errors

  • Hello,

    I don’t know what has gone wrong with the wp-supercache plugin, but it has locked my blog inside a “403 Forbidden” error for almost 12 hours in a row.

    Only the admin pages were fully functional all the time.

    Sometimes the blog still works for a user or another, but then again, very fast, 403 error again !

    The visitors receive this error exactly :


    You don’t have permission to access /wp-content/cache/supercache/ on this server.»

    In my server’s logs, the typical error :
    «[error] [client] [host] (13)Permission denied: file permissions deny server access: /homez.70/mydomain/www/wp-content/cache/supercache/»

    (I’m sorry but I can’t share the URL to my domain)

    Deactivating this plugin, my blog works again (but I have to find another cache plugin fast, 55 000 unique visitors per day is a bit much to ask to my server without a cache system).

    I haven’t changed something in particular since these last 12 hours, and yet, go figure…

    This thread serves as a bug report as much as a help request, if you see what may have caused it, or it you need more detailed information to tackle on that problem, feel free to ask, I’ll be glad to provide any additional required details 😉

Viewing 5 replies - 1 through 5 (of 5 total)
  • Try setting the plugin to half-on mode. It’s something to do with your server and (obviously) file permissions. The server must have very strict file permission settings. Talk to your admin and ask if PHP is running as the same user as Apache.

    Check the last point of the faq too.

    Hello, thanks for your reply,

    The strangest thing is that the plugin used to work until now, and my host clearly stated they didn’t change settings and rules.

    I can’t allow it to be just in half-on mode, with my traffic I have to be careful with my server, so for the moment I’ll try another caching plugin. I’ll do more testing when my blog it as its lowest traffic volume.

    I’ll still ask my host about Php and Apache running as the same user.

    However, looking at the user ratings for wp-supercache, for wp-supercache 0.9.8 – wordpress 2.9.1, 25% of the users report that something is wrong, so maybe something REALLY is wrong ?


    LOL, half-on mode in supercache is as fast as any other caching plugin so there’s no need to switch. 🙂

    The plugin works fine for me. Unfortunately those that couldn’t get it to work weren’t able to debug it and help me fix the problem. If something REALLY is wrong I need help from those people.

    When you write that the persons that couldn’t get it to work won’t help you debugging it, you’re pointing a problem, indeed.

    Quite unlike the “gadget” plugins that bring a small bonus, most of us the webmasters who resort to using a cache do it because they NEED it.
    At least in my case, I know that the server running my blog would be on his knees if my blog was running without a cache system at his peak hour. So, well, it isn’t possible to deliberately crash my blog for testing purposes :-/

    Mind you, outside peak hours, my servers would be able to stand my blog running without a cache for a short time, so, Donncha, tell me, I’d be happy to help.
    What is it that you would need to know, to debug the origin of the problem ? I’m of good will but I’m not a developer, so I can’t guess what is the information you may need…

    In your case I think it is the fact that Apache serves the file and PHP generates it. I bet the permissions are too strict to allow it.

    There’s not much you can do except ask about the ownership thing or do the umask change I have in that FAQ. This plugin is so low level that it can be hard to get working on some set ups. The readme.txt has tons of info on troubleshooting and solving problems.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: WP Super Cache] very frequent “403 Forbidden” errors’ is closed to new replies.