Support » Plugins » [Plugin: WP Super Cache] upgrade stops cached file listing, can;t delete specific file

  • First of all lots of thanks to Donncha, because I don’t know what I’d do without this plugin!

    But having a little problem since upgrading the plugin. The cache contents now won’t list the cached files, and I get the error message:
    Too many cached files, no listing possible.

    This is a bit strange as the number of files held in the cache is approx the same as before upgrade, when it used to list them all.

    I need the list because when I’m tweaking things on the site (esp home page) I use it to delete the specific cached file for that page – and now I can;’t access it.

    ** any idea what I can do to get the listing back?

    (I see from the changelog for an earlier upgrade there is a note Added clear_post_supercache() to clear supercache for a single post – maybe that’s the answer, but I’m not sure how to use this… it doesn’t seem to show up as an option on the settings page)

    thanks for any help you can offer

Viewing 4 replies - 1 through 4 (of 4 total)
  • The listing is now disabled if there are more than 300 cached files, but perhaps that’s too small. If you want to change it, look for the text “Too many cached files, no listing possible” and look for the checks for “300” on the previous line. Change those to a larger number and the file listing will display again.

    Hi donncha, thanks for your reply.

    Changing the numbers didn’t work – it got rid of the error message, but the link to see the cached files disappeared too. I had another look at the code where the checks for 300 were and it seemed as if it was offering two options – if more than 300 (or whatever number) cached files, then it was giving the error message. If less, it was refusing to show the link to the list at all.

    There didn’t seem to be an option for showing the actual list when the number o cached files was less than 300.

    I added this code (below, I hope!) in just after the checks for 300

    else {
    		echo "<p><a href='" . wp_nonce_url( add_query_arg( array( 'page' => 'wpsupercache', 'listfiles' => '1' ) ), 'wp-cache' ) . "#listfiles'>" . __( 'List all cached files', 'wp-super-cache' ) . "</a></p>";
    	}

    (I got this from the code in the pre-update plugin)

    That is now showing up the list, more or less – in fact it starts off showing an empty box when you click to see the list, but provides the whole list if you then click “regenerate stats”. The list disappears again if I delete a cached page, but reloading the WP Super Cache Manager page brings it back.

    That looks like it brings back the function I needed, so I’m happy…

    …but I’m slightly worried by the fact I’m not a PHP coder (as you have probably guessed) and I’m not sure if hacking about with the code in this way will make the sky fall in…

    Does that seem OK to you, or have I broken the plugin in a way that will show up with a horrible crunch somewhere down the road?

    thanks again for taking the time to answer

    I have similar problems.

    Initially I decided to use preload cache but that did not work out well for me so I dedided to disable preload again. However, the “list all cached files” option did not come back despite the fact that the total number of cached files is below 300.

    Any fix will be appreciated.

    I’ll look into it for the next version.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: WP Super Cache] upgrade stops cached file listing, can;t delete specific file’ is closed to new replies.