WordPress.org

Forums

WP Super Cache
Updated htaccess manually, Still get warning message. (4 posts)

  1. mWoods
    Member
    Posted 5 years ago #

    I have the Super Cache Plug-in installed in the mu-plugins directory that still appears after upgrading the WP 3.0. I've updated the .htacces file manually by copy/pasting the recommended htaccess txt from the Super Cache Plug-in.

    This message still appears in my Super Cache plug-in options panel.

    Mod Rewrite rules cannot be updated!

    You must have BEGIN and END markers in /home/funcity/public_html/.htaccess for the auto update to work. They look like this and surround the main WordPress mod_rewrite rules:

    # BEGIN WordPress
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Refresh this page when you have updated your .htaccess file.

    If I let it update automatically, it puts the Super Cache htaccess information below the WordPress information. When I orginally installed the plug-in, the instructions said that the Super Cache information must appear first in the htaccess file? Does it matter that this message displays in the plug-in control panel? Should I let the plug-in upgrade the htaccess file even though the information appears below the WordPress information?

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 5 years ago #

    Just put the plugin rules above the WordPress ones, and add the BEGIN/END lines around the WordPess rules. That should stop the warning message.

  3. soleil_levant
    Member
    Posted 5 years ago #

    Hi,

    I have the same problem with ordinary WP 3.0.

    I've tried all the ways.
    - update automatically or manually
    - other plugins activated or not
    - WP 2.9.2 or WP 3.0 (with WPSC in mode ON)
    - with preload or not
    - etc.

    I reduced my .htaccess to the minimum:

    with WP 3.0
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    with WP 2.9.2
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    To allow WPSC to write its rules in .htaccess, I chmoded
    .htaccess to 666. All works fine. The rules are written and the
    pages cached.

    But, after the installation, when I return .htaccess rights to 644, your plugin displays in the settings page :

    "Cannot update .htaccess
    The file /var/www/etc./httpdocs/.htaccess cannot be modified by the web server. Please correct this using the chmod command or your ftp client..."

    So to sum up, with .htaccess in 666 or 644 the plugin works fine. But, with 644 I get the above warning. Is it normal ? May I modify something in the settings to remove this warning ? Because I prefer to keep the 644 rights.

    PG

  4. soleil_levant
    Member
    Posted 5 years ago #

    To sum up, my minimal .htaccess is like this :

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    your rules...
    </IfModule>
    # END WPSuperCache

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    the standard WP rules
    </IfModule>
    # END WordPress

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic