WordPress.org

Forums

WP Super Cache
Unknown domains in cache folder; periodical stuck (14 posts)

  1. galante81
    Member
    Posted 3 years ago #

    Hello,

    Strange thing is going on on my site.. In my cache/supercache folder from time to time i can find folders with not just my site name, but also with name of some known/unknown sites.. sometimes those are warez sites, sometimes sites of some very known airline company etc.. I delete them, and then, few days/weeks later, some others are there.. inside those folders is just index.html of my site, but folder names are definitely not from my site.. I was previous on shared hosting, never had that problem. Last months i'm on my own vps, and now i have those problems. Cache folder is 755, also supercache. Should i change any of that permissions?

    I also have one other problem, i believe it is something related to wp-supercache, but not 100% sure. Once or twice a day my vps get stucked, and my tmp folder is full with files ending with MYI and MYD. Those files go up to 100MB, there can be up to 45 of them, i think i never saw more. Files are being deleted, and then once again being created. I opened some of those files, and they are full with links of posts on my site and comments. wp-supercache-gc is being mentioned a lot of times in those files.. I have strong vps, 4 cores, 2Gb ram, a lot of free space and 4 gb swap, but site becomes unreachable for half an hour or whole hour. I have 5.000 posts and 75.000 comments, also 15.000 visits daily average. And even in peak times, vps is not so stucked like in those moments. Yesterday i thought it may be because of wp-supercache preload mode which works with so many posts (i tried to set it to work with smaller number, but whenever i publish a new post number goes back to preload "all"), so i disabled preload mode, but id like to have it enabled of course. I'l see now can this be a problem, or garbage collector.. Can you recommend good settings for gc for my site? A lot of new comments (hundreds per day average), average 10 new posts daily.. GC is now using default settings.

    Thanks for any help and suggestions in advance.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    The first problem is bots hitting your website trying to attack it and guessing at host names that someone on the server might be using. WordPress answers all queries, returning a 404 or even showing your homepage and those directories are created that way. I may look into putting a check against the "home" option but that may have unforseen consequences..

    Those are MySQL files in your tmp directory, I think. Looks like MySQL might not be configured properly but I've never heard of what you're seeing.

    Have you got the cache rebuild option set in WP Super Cache?

  3. galante81
    Member
    Posted 3 years ago #

    Thank you for answers Donncha.

    I know those are MySQL files, just do not know why is there so many of them once a day (only process being run once a day on my server related to wordpress is wp-supercache preload mode) and why do they stuck my vps.. Yes, cache rebuild is enabled, why?

    About first problem.. you think it's nothing to worry about?

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Yeah, I wouldn't worry about those extra directories.

  5. James Revillini
    Member
    Posted 3 years ago #

    I think there is something to worry about. I haven't dissected the code enough to know for sure, but I have a hunch that if your WP admin is at domain1.com, and if your site can also be hit at domain1.domain2.com, that when a page is updated, it only updates the cached version in the /wp-content/cache/supercache/domain1.com folder, but not the version in /wp-content/cache/supercache/domain1.domain2.com folder. Can anyone confirm or disconfirm? I'm going to run some tests and look through the code.

  6. James Revillini
    Member
    Posted 3 years ago #

    I can confirm this on my site with the following live URLs (I don't know what the preload cache function will do ... it may nuke the cache and then this these files will become identical). The first URL has "++++" at the bottom and the second does not. Both are served from the same server, same WP install.

    http://tunxis.edu/college-information/graduation/faq/
    http://www.tunxis.commnet.edu/college-information/graduation/faq/

    Going to WP Super Cache settings, Contents tab, and clicking Delete Cache does not fix it.

  7. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    I have actually fixed this issue in the dev version!

    http://downloads.wordpress.org/plugin/wp-super-cache.zip

  8. James Revillini
    Member
    Posted 3 years ago #

    You da man! Will try soon.

  9. James Revillini
    Member
    Posted 3 years ago #

    Installed dev version but getting same results. Click the two links I posted above. The first shows '****' below the contact info, the second shows '&&&&'.

    Wouldn't there need to be somewhere in the interface to specify the alternate domains?

  10. James Revillini
    Member
    Posted 3 years ago #

    OK I've augmented my local version of the dev version that I installed from the above link. I've added a new configuration area to the Advanced tab which allows you to list "other domains" that your WordPress site is accessed by. You list them, one per line, save it, and next time you delete cache, it also goes into the other directories and tries to delete from them as well. Seems to be very effective here. Still testing. Will post the fix soon.

  11. Kevin
    Member
    Posted 3 years ago #

    It sounds like this may be a similar issue to what I'm seeing. I have posted in
    http://wordpress.org/support/topic/plugin-wp-super-cache-change-of-blog-address-creating-cache-errors?replies=2

  12. James Revillini
    Member
    Posted 3 years ago #

    @Kevin It's in the same ballpark, but its the reverse of the problem we have, which is really strange! In your issue, you're saying it's NOT generating cache files for the alternate domain. Our issue is that is is, but then it's never refreshing them when pages/posts are changed, nor when the admin clears the whole cache.

  13. James Revillini
    Member
    Posted 3 years ago #

    Well, I'm happy to report that my modifications are working very well. I notice no performance hits and cache pages are getting cleared for every domain when they're supposed to.

    Changes had to be made to wp-cache.php, wp-cache-config-sample.php, wp-cache-phase1.php, and wp-cache-phase2.php. haha. no big deal. here are the replacement files which are forked from the DEVELOPMENT version of the plugin that I downloaded a few days ago. ALSO note that included in these files is a change which creates new capabilities that effectively make Editors able to edit pages and have the cache cleared when they do (see http://bit.ly/JGCjkL). So I wouldn't use this code unless you really know what you're doing.

    wp-cache.php: http://pastebin.com/JTJ2SDX8
    wp-cache-config-sample.php: http://pastebin.com/UuHVtv71
    wp-cache-phase1.php: http://pastebin.com/FpxfAa4Q
    wp-cache-phase2.php: http://pastebin.com/gy3upAi2

  14. James Revillini
    Member
    Posted 3 years ago #

    Oh and I guess I should post some usage instructions. First, don't use this code unless you're messing with the development version of super cache and you downloaded it very close to the date I'm writing this.

    1. replace or merge relevant files using pastebin pastes above. should be fairly self explanatory.
    2. deactivate and activate the plugin - I know ... pain in the ass but if you don't, your admin is not going to have rights to mess with supercache at all.
    3. go to settings > wp super cache
    4. set all your stuff up
    5. go to the advanced tab and in the OTHER DOMAINS box (I added this), list the URLs that your wordpress site can be accessed on.
    6. Click Save Domains.
    7. Click delete cache and check out the subfolders of supercache. They should have all gotten cleared out.

    Go about your business. Everything will be awesome.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic