Support » Plugin: WP Super Cache » [Plugin: WP Super Cache] Supercache Refresh Question

  • I’ve got a product based site and supercache does an awesome job of serving my pages up quickly. 🙂

    My question is this…
    I’m in the process of rebuilding the sidebar menu which is displayed on every product page. These product pages are custom post types and there is also a top level custom taxonomy page linked in the menu structure. Once I create the product page, there is usually no reason to go back and edit it. Everything is managed through my custom post template.

    As I update the menu or tweak the template, how long does it usually take before one of my product pages gets refreshed in the cache? I know I can flush the cache, but I hate to do that as it takes a painfully long time for a non-cached page to load due to external api calls and I have 500+ custom posts. I would hate to do that to visitors each time I make a minor update to the template.

    So does Supercache rebuild the entire cache directory at some point and how long does that take?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Donncha O Caoimh


    Check your advanced settings page, cache expiry details are all set by you the user.

    Thanks – I do have those set. I guess my real concern is that when those pages expire, will another one immediately be generated by the plugin or will that happen only when the page is hit again?

    I want to be absolutely certain that my visitors (and bots) are hit with a cached page at all times because of the uncached (product) page being such a beast to load uncached.

    Based on the recommendations, I have my settings as:

    Cache timeout: 0
    Timer: 86400

    Pre-load Refresh: 86400
    Preload mode: checked
    Preload tags, categories and other taxonomies: checked

    Does this look correct for what I need?

    Plugin Author Donncha O Caoimh


    If you use preloading then the pages on your site won’t expire (if not cleared by an action like posting a comment or updating a post) but will be regenerated by the preload. Users won’t see an uncached page, I hope!

    Thanks Donncha – I appreciate the clarification.

    I’ll keep an eye on it for a few days and make sure the product pages are still loading quickly. I think I’ve got things set the way I need them now. 🙂

    Ok – ran into a snag I guess. Just went back to check my site and the pages that were previously cached this morning when I checked, are no longer cached. 🙁

    I am not logged in to the site, but they are taking forever to load again. Am I missing something obvious?

    Uhh – it looks like all my settings got reset? What would cause that?

    OK – nevermond – the settings are right….but this is what the logs show now when I click on a page…

    17:59:45 /gifts-for-girls/baseball/ Output buffer callback
    17:59:45 /gifts-for-girls/baseball/ Supercache disabled: GET or feed detected or disabled by config.
    17:59:45 /gifts-for-girls/baseball/ Gzipping buffer.
    17:59:45 /gifts-for-girls/baseball/ Writing gzipped buffer to wp-cache cache file.
    17:59:45 /gifts-for-girls/baseball/ Renamed temp wp-cache file to /home/girlcaw6/public_html/wp-content/cache/wp-cache-e43439074a6f7462af568c98e38e8184.html
    17:59:45 /gifts-for-girls/baseball/ Writing gzip content headers. Sending buffer to browser
    17:59:45 /gifts-for-girls/baseball/ wp_cache_shutdown_callback: collecting meta data.
    17:59:45 /gifts-for-girls/baseball/ Writing meta file: /home/girlcaw6/public_html/wp-content/cache/meta/wp-cache-e43439074a6f7462af568c98e38e8184.meta

    Why is it saying SuperCache is disabled?

    I now have a message at teh top of the supercache settings that says Couldn’t resolve host ‘’

    The site loads fine on the front end.

    Ok – here’s an update… I reset everything and it seemed to be working fine as I tested it throughout the afternoon and evening yesterday from various devices.

    This morning I checked those same pages again, and now those same custom taxonomy pages that were showing as cached yesterday, are no longer being cached again.

    I still get the message “Supercache disabled: GET or feed detected or disabled by config.” and when I look into my ftp directory, no supercache files are being generated for those pages. The folders are there, but they are empty.

    In fact, it seems that all of the folders were wiped out at some point and the only ones there now are the ones I clicked on this morning during my test.

    Can you help me figure out why those pages are not caching properly or not staying cached? I am stumped.

    Ok – did some more digging. I am noticing that any of the pages displaying my products are not generating supercache files. Normal pages, contact forms and blog posts all generate a supercache file. Any page that displays my products (from a feed) are not generating a supercache page.

    To be certain this is the pattern, I loaded one blog post that also had a product feed. It did not generate a supercache page – only a folder. I then loaded another blog post with no products and it did generate a supercache file.

    Is there a way to make supercache generate a file for these types of pages? Why is it not generating the file?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: WP Super Cache] Supercache Refresh Question’ is closed to new replies.