Support » Plugins and Hacks » [Resolved] [Plugin: WP Super Cache] Supercache folder only contains empty subdirectories

[Resolved] [Plugin: WP Super Cache] Supercache folder only contains empty subdirectories

  • I installed Supercache 0.6.7 on WordPress 2.5.1. While cashed pages getting served now and data clutters up the wp-cache and meta directories, the supercache directory only contains empty subdirectories, but no files.

    The troubleshooting section of the readme file states the following:

    7. Look in wp-content/cache/supercache/. Are there directories and files there?

    Unfortunately it doesn’t provide any hints how this issue can be solved.

    Thank’s for any advice,

Viewing 15 replies - 1 through 15 (of 22 total)
  • Yes, I am getting the same issue. WP-cache is caching pages but WP-Super cache is not caching any pages. It just creates empty directory with name of the post’s permalink. This is happening after the latest update.

    Any suggestions? help?
    I am using wp 2.6.1 with Wp-supercache 0.7.1 with eaccelerator.

    After the upgrade (0.7.1) the source code of my pages still look like this:

    <!-- Dynamic Page Served (once) in 0.996 seconds -->
    <!-- Cached page served by WP-Cache -->

    While the default cache is working, supercache only creates empty directories. Php safe_mode is off. Compression is turned off. No special plugins are installed.

    Is there some error-log function I can activate? Unfortunately I cannot access the php error_log.

    Anyway, uninstalled it.

    Same problem. I’m getting ready to uninstall it too. I tried to rate it one star but the WordPress rating script is broken too. :o(



    Same issue here. When I try to create a “directly cached file” all I get is a blank subdirectory served up.

    ideas? looks like no.

    Resolved? I’m still seeing this problem with the latest release.

    Same here… only empty directories…

    Me too, installed it across a dozen websites last night and not a single cache file exists.

    I am getting the same problem with the latest version 0.85. The supercache only has empty directories, with no files.

    Do you have safe_mode on? What does ini_get( ‘safe_mode’ ); return? It should return false, but may return the string ‘Off’ for some reason.

    I need more details about your webserver – Apache, PHP, modules loaded, configuration? Any security checks?

    I am in the same case,
    My safe_mode in php.ini is set to Off
    (Off is the normal configuration for safe_mode)

    And my directory in supercache/ are empty too

    In my case, safe_mode is Off.

    PHP version: 5.2.6
    Apache version: 2.2.8

    Configure command: Command ‘./configure’ ‘–enable-bcmath’ ‘–enable-calendar’ ‘–enable-exif’ ‘–enable-ftp’ ‘–enable-gd-native-ttf’ ‘–enable-libxml’ ‘–enable-magic-quotes’ ‘–enable-mbstring’ ‘–enable-pdo=shared’ ‘–enable-soap’ ‘–enable-sockets’ ‘–enable-zip’ ‘–prefix=/usr’ ‘–with-bz2’ ‘–with-curl=/opt/curlssl/’ ‘–with-curlwrappers’ ‘–with-freetype-dir=/usr’ ‘–with-gd’ ‘–with-gettext’ ‘–with-jpeg-dir=/usr’ ‘–with-libdir=lib64’ ‘–with-libxml-dir=/opt/xml2’ ‘–with-libxml-dir=/opt/xml2/’ ‘–with-mcrypt=/opt/libmcrypt/’ ‘–with-mhash=/opt/mhash/’ ‘–with-mime-magic’ ‘–with-mysql=/usr’ ‘–with-mysql-sock=/var/lib/mysql/mysql.sock’ ‘–with-openssl=/usr’ ‘–with-openssl-dir=/usr’ ‘–with-pdo-mysql=shared’ ‘–with-pdo-sqlite=shared’ ‘–with-pic’ ‘–with-png-dir=/usr’ ‘–with-pspell’ ‘–with-sqlite=shared’ ‘–with-ttf’ ‘–with-xpm-dir=/usr’ ‘–with-xsl=/opt/xslt/’ ‘–with-zlib’ ‘–with-zlib-dir=/usr’

    I’ll be happy to supply any more info asked for.

    Interesting, PHP5, anyone else on this thread using PHP5? Are you using Fastcgi?

    I use PHP 5 too and eAccelerator
    Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.3 with Suhosin-Patch

    What ftp clients are you using when checking the supercache directory? Just out of curiosity, can you try another one?

    Djay77 – any chance you could give me login details to your hosting account so I can try to figure this out? I checked a dreamhost account this afternoon and the supercache folders did have index.html files. It started working somehow before I got a chance to debug it!

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] [Plugin: WP Super Cache] Supercache folder only contains empty subdirectories’ is closed to new replies.