WordPress.org

Support

Support » Plugins and Hacks » WP Super Cache » [Resolved] [Plugin: WP Super Cache] Super Cache not caching mutlisite on preload

[Resolved] [Plugin: WP Super Cache] Super Cache not caching mutlisite on preload

  • Hello,

    I’m on the most recent version of both WordPress and Super Cache, and everything is working great except that preloading the cache ONLY works for our main site and not our other WordPress sites in a single multisite setup.

    There are around 300 pages on http://example.com and they are all preloaded just fine, but example.com/site2, example.com/site3, and example.com/site4 are not preloaded by hitting the “preload now” button.

    The other sites ARE cached after someone visits them, however. It’s only preloading that doesn’t work.

    Any idea what might be the problem?

    http://wordpress.org/extend/plugins/wp-super-cache/

Viewing 2 replies - 1 through 2 (of 2 total)
  • it was possible to go to every blog’s dashboard logged in as network admin, go to super cache page there, and some fields there, for example, cdn url, referred to that blog. maybe “preload” there would work for that blog. may be it works also with newest version of wordpress.

    I did have the most recent version of WordPress (3.2.1.) and Super Cache.

    However, it looks like the problem might have been my multisite setup. I was not the original one who set it up, and I was missing two lines from wp-config.php.

    define('MUTLISITE', true );
    define('SUBDOMAIN_INSTALL', false );

    I also noticed that Minify was not working on each site, as it seems a network activate of that plugin does NOT actually activate it on other sites. You must manually go in to each site and activate those settings. Not related necessarily to Super Cache but thought it might be helpful to someone down the road.

    Preloading on any Super Cache settings page for any site now seems to preload for every site, which is what I needed.

    Great plugin!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] [Plugin: WP Super Cache] Super Cache not caching mutlisite on preload’ is closed to new replies.
Skip to toolbar