WP Super Cache
Super cache - new content isn't reloading on all pages (3 posts)

  1. macwriter4
    Posted 5 years ago #

    WP Super Cache Manager is my issue. Using WP 2.9.2.

    If I add new content to home page (i.e. update my twitter status that runs in the sidebar), the updated content may show up on one page but not on the home page that is the default. It still shows the content from like 10 days ago. If I hit refresh in my FireFox browser, it still shows the old content. I am logged out of WordPress as I do this by the way.

    I realize that the idea of a cache would mean that old content may show up for some period of time but not for several days.

    Any thought in terms of what's going on with the caching-can I get the home page to reload new updated content on a more regular basis, as I can with the "about" page?

    My server / host is Godaddy's WordPress hosting package.

    I use a custom permalink structure:

    So I set cache status at "Half on" (per the tip from the Super Cache developer for such permalink structures).

    My home page is not a static home page (it's supposed to load the latest blog posts)

    Checked the box for: Don't cache pages for logged in users

    Checked the box for: Cache rebuild. Serve a supercache file to anonymous users while a new file is being generated.

    Expiry time: 3600 seconds

    Garbage Collection
    Last GC was 01:23 minutes ago
    Next GC in 08:37 minutes

    Lock down is enabled

  2. topstarnec
    Posted 5 years ago #

    I think "Lock down" should be disabled because Cache rebuild is enabled.

    Expiry time can be set to 900 seconds that can automotivly update the changed pages every 15 minites including the homepage.

  3. Donncha O Caoimh
    Plugin Author

    Posted 5 years ago #

    You had the front page on lockdown?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic