WP Super Cache
Super Cache Multisite Domain Mapping Not Working (5 posts)

  1. jeffvand
    Posted 4 years ago #

    I was able to recently get my wordpress multisite working for all subdomain sites. It works great now and clears the cache for an individual subdomain site on the network. Here is the thread about that change.


    Now I have run into another problem. It appears that the super cache plugin is not clearing the cache when new pages or posts are updated for domain mapped sites. I have the domain mapping plugin box checked in options. I am wondering if this is related to the wordpress MU upgrade to multisite again.

    I did a test on a new multisite network (not upgraded from MU) and the domain mapping tool is working as expected... but it is not working in my network I upgraded.

    I am wondering if you can tell me what the plugin is looking for in order to do the domain mapping bit. Is it something in the wp-config file like the multisite one was doing? I have the "define('WP_ALLOW_MULTISITE', true);" in the config file now, but not the "define( 'MULTISITE', true );" because calls a different database structure.

    Thanks for any help you can offer.


  2. jeffvand
    Posted 4 years ago #

    Did some more testing today and found a couple of things.

    1st - We had our wp-content in a different location and defined in the wp-config file. Something like this:

    define( 'WP_CONTENT_DIR', '/location-of-content/wp-content' );

    When I removed that and then used the domain mapping plugin suggested: http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/ it worked. Wahoo.

    I have been using the wpmudev domain mapping plugin (http://premium.wpmudev.org/project/domain-mapping/) because it plays nice with shibboleth (which we are using for authentication). I am trying to get the other plugin to play nice with shibboleth now. It may be a setting thing on the plugin. There are lots of options in the plugin.

  3. jeffvand
    Posted 4 years ago #

    Oh wait.. but I have another environment that was not upgraded from wordpress MU that is running wpmu's domain mapping plugin and is working well and playing nice. Man... now I'm confused again....

    More testing to come..

  4. jeffvand
    Posted 4 years ago #

    Hey Donncha, we tried the debugger on a domain mapped site. This is the result. Does anything stick out to you here?


    Thanks for your help!

  5. jeffvand
    Posted 4 years ago #

    So we are continuing to troubleshot this. A bit more info as we find it. One difference we found between our multisite and a working multisite is that the delete cache button is showing up on the toolbar on the working site.

    It also appears that the "Delete Cache" button under contents is working on non-domain mapped sites, but not working on domain mapped sites.

    We are looking further for what function is making the domain cache clear to see if we can see something there.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic