Support » Fixing WordPress » [Plugin: WP Super Cache] Super Cache killed my RSS feed

  • Because of the load on my server, my webhost recommended that I install the wp-Super-Cache plugin to reduce the number of php scripts running on the machine. It looks like it’s caching and serving pages properly and is running well.

    However, I’ve noticed that my IE 7 RSS feeds will not update now and shows an error of: “Feeds with DTDs are not supported.” Also, new posts are not appearing in Bloglines or elsewhere.

    How do I resolve this feed problem without disabling wp-super-cache, since it looks like the super-cache is going to be very helpful in terms of the server load?

    Thanks!
    Preston
    preston@sixmeatbuffet.com

Viewing 15 replies - 1 through 15 (of 23 total)
  • Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Add “feed” to the list of “Rejected URIs” on the super cache config page. Then clear the cache. Feeds then should not be cached anymore.

    Thanks Otto – I had added some of the rss & atom files, but that didn’t do it – your suggestion worked like a charm. Thanks!!!!

    Otto – sorry to reopen this, but as soon as caching started back up, the RSS feed went down again, even though “feed” is in the relected URI list. Any other suggestions? Thanks!

    I also removed wp-rdf.php, wp-rss.php and wp-rss2.php from the list of files to cache, otherwise it was getting served up as text/html and not text/xml..

    oops – and don’t forget to delete your cache!

    Thanks Chris – I will make that change now and see how it goes!

    Hmm. My RSS feed is still killed – according to some readers and Feedburner.

    http://feeds.feedburner.com/Arsgeek

    Does anyone know of a problem with outsourcing feeds to Feedburner?

    I’ve tried a bunch of stuff – Here are my strings that force pages not to be cached:

    wp-.*.php
    rss2
    rss
    atom
    feed

    And here are my filenames that can be cached:

    wp-comments-popup.php
    wp-locations.php

    When I use Feed Validator on my feed it tells me that it looks like it’s a web page, not a feed.

    Suggestions?

    Thanks in advance,
    Ben

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Okay, FeedBurner is it’s own beast. FeedBurner problems have nothing to do with your blog or any plugins on it.

    If you want to diagnose a problem, turn off FeedBurner, look at your feed directly. Validate your feed directly. If it has no issues, then the problem is in FeedBurner somewhere.

    Deal with problems in pieces that can be handled. Trying to figure out a problem with a feed when it’s going through feedburner is like trying to figure out how much it’s rained in Chicago while actually looking at the Mississippi River in New Orleans. 😉

    Well, if you want to get technical about Chicago rainfall with the Mississippi. . . ahhh I got nothing.

    Feeds do work when straight from my site – not through Feedburner when Super Cache is enabled.

    They validate absolutely fine however through Feedburner when Super Cache is disabled. They also worked fine with plain old vanilla WP-Cache.

    Leading me to believe it does have something to do with Super Cache? When it’s off, my RSS works through feedburner. When it’s on, it doesn’t and appears as an HTML page.

    When it’s off, my feeds appear as valid RSS.

    EDIT – actually, with SC on and going straight through my site, it’s not validating either.

    1420. <!– Dynamic Page Served (once) in 1.293 seconds –>
    1421. <!– super cache gz –>

    It’s not supposed to be caching the feed stuff but I still get that when I look at the source.

    Grab the phase1 and 2 files from http://svn.wp-plugins.org/wp-super-cache/trunk/ and copy them into your plugins/wp-super-cache/ folder and clear your cache.

    That should fix the problem with feeds not showing.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    stynx9000: Did you clear the cache after adding “feed” to the reject list? That’s important, you gotta do that.

    Hey Donncha and Otto42.

    I did clear the cache afterwards – and turned off/on the plugin, etc. donncha – the two new phase1/2 files did the trick! Many thanks!

    Ben

    I’ve done what stynx has done, but my feeburner still doesn’t work. I’ve added the two files mentioned, put feed on the reject list, but still my feed doesn’t work when supercache is enabled.

    I managed to resolve this by changing the FeedBurner feed address. Here are the steps:

    1) Log into your FeedBurner account
    2) Click your feed title, then “edit feed details”
    3) Change the “original feed” field from http://myblog.com/?feed=rss2 to http://myblog.com/feed/rss2
    4) Click “save feed details”
    5) Login to your WP admin
    6) Click the “settings” tab
    7) Click the “WP Super Cache” link
    8) Scroll down and click “Delete cache”
    9) Log out and visit your homepage

    That’s it! Hope it helps.

    NickDC,

    I’ve been looking for, and waiting for a solution to the feedburner problem, and your url change fixed my problem. I can now use WP Super Cache again. Thank you.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Plugin: WP Super Cache] Super Cache killed my RSS feed’ is closed to new replies.