WordPress.org

Support

Support » Plugins and Hacks » WP Super Cache » [Plugin: WP Super Cache] super cache does not work when site url different with homepage url.

[Plugin: WP Super Cache] super cache does not work when site url different with homepage url.

  • hwaming

    @hwaming

    I found that when I change site address different with install folder at general setting, the super cache pluging will not work, or it can’t be working correctly.

    it is a bug

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Donncha O Caoimh

    @donncha

    How doesn’t it work? I’ve tested with the site address different to the install folder and it works for me. Was it .htaccess rules or something? You probably need to regenerated them.

    hwaming

    @hwaming

    when I change it , then go to super cache config , it will show

    “Rewrite rules must be updated
    The rewrite rules required by this plugin have changed or are missing. Scroll down the Advanced Settings page and click the Update Mod_Rewrite Rules button.”

    but scroll down the advance setting, their do not have update mod_rewrite rules button. only show :

    Mod Rewrite rules cannot be updated!
    You must have BEGIN and END markers in /.htaccess for the auto update to work. They look like this and surround the main WordPress mod_rewrite rules:

    # BEGIN WordPress
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPressRefresh this page when you have updated your .htaccess file.

    and it can’t be generated, always 0 page regenerated.

    but I change the site homepage url back same as install folder, everything are ok.

    hwaming

    @hwaming

    I install in sub-folder

    hwaming

    @hwaming

    install directory /wordpress/
    but site address set to /blog/

    they are ok for both /wordpress/

    then got problem.

    Plugin Author Donncha O Caoimh

    @donncha

    You need the BEGIN and END comments around the WordPress rules in your .htaccess, that’s why it’s not updating. The rewrite rules are shown on the settings page so you can edit the .htaccess yourself and make sure they match. Sometimes it’s necessary unfortunately.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: WP Super Cache] super cache does not work when site url different with homepage url.’ is closed to new replies.
Skip to toolbar