WordPress.org

Forums

[Plugin: WP Super Cache] Settings page hits maximum execution time (6 posts)

  1. Richard5
    Member
    Posted 6 years ago #

    I've just started using the plugin on a 2.5.1 blog, it's been running succesfully for two weeks but currently I'm unable to access the settings page fully as it hits the maximum execution time for php scripts:

    Fatal error: Maximum execution time of 30 seconds exceeded in /Library/WebServer/Documents/diymacserver/wp-content/plugins/wp-super-cache/wp-cache.php on line 961

    It does this at the "cache contents" section of the settings page. Any idea how to resolve this. Running PHP 5.2.5 on Mac OSX Leopard.

  2. Richard5
    Member
    Posted 6 years ago #

    Just to add some more info, today I'm getting a long list of error messages in the settings page at the same place. They might help to tell you what is wrong.

    Warning: glob() [function.glob]: Pattern exceeds the maximum allowed length of 1024 characters in /Library/WebServer/Documents/diymacserver/wp-content/plugins/wp-super-cache/wp-cache.php on line 961

  3. Donncha O Caoimh
    Member
    Posted 6 years ago #

    Looks like you have a *huge* cache directory. Is your blog big?

  4. Richard5
    Member
    Posted 6 years ago #

    Not really I think, 70 posts and 60 pages. It's on diymacserver.com. The cache directory has 315 files.

  5. Donncha O Caoimh
    Member
    Posted 6 years ago #

    The 1024 char warning is probably from a long filename then. I don't think there's much I can do for that, except maybe move from using glob()

  6. Richard5
    Member
    Posted 6 years ago #

    Yes, that might be it, I've got at least 3 levels of hierarchy in my pages documents. Besides the settings page loading problem which is visible, are there other things I need to worry about when using super cache with long URL's ?

    If there aren't any other issues, I don't mind the lading problem in the settings page. Everything is set and don't need to access it any more. I guess if I need to, clearing the Cache should solve the problem.

    Thanks for your help.

Topic Closed

This topic has been closed to new replies.

About this Topic