WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WP Super Cache] Preload Cache Now button doesn't do the job

[Resolved] [Plugin: WP Super Cache] Preload Cache Now button doesn't do the job

  • Haoxian
    Member

    @lonelicloud

    Hi,
    I just upgraded to the latest version of WPSC right now. But the problem I found is that when I click the button “Preload Cache Now” on page of “Preload”, it says to rebuild the super cache files but after about 30 minutes, the super cache files are not generated.

    Instead, if you open a webpage in the browser, the webpage then is generated in the supercache dir.

    What can I do?

    Here is the debug info I got:

    No wp-cache file exists. Must generate a new one.

Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Author Donncha O Caoimh
    Member

    @donncha

    Strange. Check your access_logs for hits on wp_cron.php

    Do scheduled posts work on your host?

    Haoxian
    Member

    @lonelicloud

    Thank you, donncha!

    But I don’t know how to check the access_logs for hits on wp_cron.php.

    Could you give a hint?

    Plugin Author Donncha O Caoimh
    Member

    @donncha

    It’s different on every host unfortunately. You should talk to your hosting support about it.

    Haoxian
    Member

    @lonelicloud

    Something new:

    The “Preload Cache Now” button DO clear the old supercache files, but don’t generate new files.

    I also get a message from debug like that:
    supercache dir: xxx/htdocs/wp-content/cache/supercache/cnzhx.net/wp-admin/options-general.php/

    Does this means that WPSC is attempting to cache a wp-admin webpage?

    Could I downgrade WPSC to version 0.9.9.3 ? This problem occurred only after the upgrading. And I’m using WP 3.1 alpha.

    Plugin Author Donncha O Caoimh
    Member

    @donncha

    Something weird happening on your server. It shouldn’t try to cache wp-admin hits! Sure, you can downgrade but it won’t fix the problem long term as you may want to upgrade in the future..

    Haoxian
    Member

    @lonelicloud

    I don’t know how to fix it, so, just let it be.

    Maybe, it’s a compatible issue between wp 3.1 alpha and this new version wpsc.

    Thank you, donncha! You’re so appreciate!

    Haoxian
    Member

    @lonelicloud

    OK, I found the reason.

    That’s because the webhosting server restricted the cron job feature, and had nothing to do with the WP or this wonderful plugin of WPSC.

    Marcelo Pedra
    Participant

    @kent-brockman

    Hi there people, I want to comment I’m also seeing the same issue about this: The “Preload Cache Now” button DO clear the old supercache files, but don’t generate new files.
    I’m using WP 3.0.1 and WPSC 0.9.9.6. I’ve setted preload cache with this settings:

    – Refresh preloaded cache files every 0 minutes. (I don’t update too often the blog, so it’s a non-sense to update cache often)
    – Preload mode: marked

    The “Preload Cache Now” button DO clear the old supercache files, but don’t generate new files. I have to delete entire cache first, then preload. Is there any workaround? is this a bug? My blog have about 900 posts and it is permanently visited, so deleting the cache in order to be able to preload impacts negatively in my poor server. If WPSC could only regenerate those files after deleting them, the magic would be complete 😉

    Any hint?

    Plugin Author Donncha O Caoimh
    Member

    @donncha

    Kent Brockman – try the development version, from the “Other Versions” page linked from the plugin homepage here. That may help.

    Haoxian
    Member

    @lonelicloud

    As I pointed out that after I moving to another host, the problem had never showed up again.

    I also write about this in Simple Chinese (because I am not sure whether I can write it in English).

    If you are interesting, here is the post. If you could not read Simple Chinese, you could use Google translate.

    By the way, Kent Brockman, are you using a free hosting plan like xtreemhost.com?

    Marcelo Pedra
    Participant

    @kent-brockman

    ok donncha, you say that the behaviour I’m seeing is not normal? When Preload Cache now is pressed it should regenerate all the cache files, right?

    lonelicloud – I run my own VPS server. Maybe I some preferred setup is needed I can check and eventually recompile Apache and PHP if I don’t have the needed plugins, like gzip (which I have of course already installed).

    Plugin Author Donncha O Caoimh
    Member

    @donncha

    Kent Brockman – yes, it preloads all posts and pages, but not archive files. Or should do.

    Also try the debug system built into the plugin. That will help a great deal!

    Marcelo Pedra
    Participant

    @kent-brockman

    Hi donncha, I’ve installed the development version and now it is not deleting the cache files when I click “Preload Now”. However, those cache files aren’t being updated. Is this normal because the posts have not be updated too?
    Is there any way to manually force Preload without having to set “Garbage Collection” to another value than 0 and “Refresh preloaded cache files” to another value than 0 minutes?

    All this is due to my template, which read dynamic php data from a third party db and publish those ads using HTML. The only way I have to update those ads is deleting cache, and then, Preload now..

    Plugin Author Donncha O Caoimh
    Member

    @donncha

    When you click “Preload Now”, your blog should update all the posts on your site, but it could take anywhere from a few minutes to a few hours depending on how many posts you have. (It can’t do all posts instantly)

    Obviously something is going wrong on your site, try the debug system and check the log as there might be something that that will tell you why it’s not working.

    You should display those ads using Javascript like Google Adsense does. Don’t tell me it can’t be done, because it can 🙂

    Marcelo Pedra
    Participant

    @kent-brockman

    Hi there donncha, I’ve upgraded to the development version and it simply cached the whole site more quickly. When I click “Preload Now”, the blog should only update the cache file only if there are new posts? or not?

    The debug system didn’t show relevant info. But, all in all, I turned the ad system to a .js array based source and at less the ads are being more dynamically updated without having to touch the cache. Good idea. Thanks!

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Resolved] [Plugin: WP Super Cache] Preload Cache Now button doesn't do the job’ is closed to new replies.