WP Super Cache
preload cache not working (6 posts)

  1. ncklln
    Posted 4 years ago #

    HI - Your plugin is great and is really helping my unuseably slow e-commerce site, but I can't get the cache to preload... have read every blog and forum and tried everything, but no. Is it a bug in this version?

    here's an example debug log http://www.pussyhomeboutique.co.uk/s-c.txt

    thanks in advance



  2. Donncha O Caoimh
    Plugin Author

    Posted 4 years ago #

    Your "shop/products-page/moomins/moominvalley-in-november/" page was cached but if preload isn't working try the cronview plugin to see that the job was scheduled.

    You'll have to keep debugging enabled until at least after the preload is supposed to have started. The log should tell you that preloading has started. You should also see mention of wp-cron.php there.

  3. ncklln
    Posted 4 years ago #

    Thanks so much for taking the time to reply - I think the problem is that they're 'products' though - you replied to my other post saying that only 'posts' and 'pages' are supported in the preload feature. Damn! I don't suppose there's a work-around?

    thanks again

  4. Donncha O Caoimh
    Plugin Author

    Posted 4 years ago #

    If they're listed in the posts table then the preload should find them. Enable debugging before you preload and watch the logs.

  5. ncklln
    Posted 4 years ago #

    enabled debugging then hit 'preload cache now', this is the debug log
    thanks again Donncha

    16:32:32 /shop/wp-admin/options-general.php?page=wpsupercache&tab=preload Cookie detected: wordpress_logged_in_5c58e78c5ead69af1211c5eb970a125a
    16:32:32 /shop/wp-admin/options-general.php?page=wpsupercache&tab=preload supercache dir: /vhost/vhost11/p/u/s/pussyhomeboutique.co.uk/www/shop/wp-content/cache/supercache/www.pussyhomeboutique.co.uk/shop/wp-admin/options-general.php/
    16:32:32 /shop/wp-admin/options-general.php?page=wpsupercache&tab=preload No wp-cache file exists. Must generate a new one.
    16:32:33 /shop/wp-admin/options-general.php?page=wpsupercache&tab=preload Cookie detected: wordpress_logged_in_5c58e78c5ead69af1211c5eb970a125a
    16:32:33 /shop/wp-admin/options-general.php?page=wpsupercache&tab=preload In WP Cache Phase 2
    16:32:33 /shop/wp-admin/options-general.php?page=wpsupercache&tab=preload Setting up WordPress actions
    16:32:33 /shop/wp-admin/options-general.php?page=wpsupercache&tab=preload Not caching wp-admin requests.
    16:32:38 /shop/wp-admin/options-general.php?page=wpsupercache&tab=preload Cookie detected: wordpress_logged_in_5c58e78c5ead69af1211c5eb970a125a
    16:32:38 /shop/wp-admin/options-general.php?page=wpsupercache&tab=preload In WP Cache Phase 2
    16:32:38 /shop/wp-admin/options-general.php?page=wpsupercache&tab=preload Setting up WordPress actions
    16:32:38 /shop/wp-admin/options-general.php?page=wpsupercache&tab=preload Not caching wp-admin requests.
    16:32:48 /shop/wp-admin/options-general.php?page=wpsupercache&tab=debug Cookie detected: wordpress_logged_in_5c58e78c5ead69af1211c5eb970a125a
    16:32:48 /shop/wp-admin/options-general.php?page=wpsupercache&tab=debug supercache dir: /vhost/vhost11/p/u/s/pussyhomeboutique.co.uk/www/shop/wp-content/cache/supercache/www.pussyhomeboutique.co.uk/shop/wp-admin/options-general.php/
    16:32:48 /shop/wp-admin/options-general.php?page=wpsupercache&tab=debug No wp-cache file exists. Must generate a new one.
    16:32:49 /shop/wp-admin/options-general.php?page=wpsupercache&tab=debug Cookie detected: wordpress_logged_in_5c58e78c5ead69af1211c5eb970a125a
    16:32:49 /shop/wp-admin/options-general.php?page=wpsupercache&tab=debug In WP Cache Phase 2
    16:32:49 /shop/wp-admin/options-general.php?page=wpsupercache&tab=debug Setting up WordPress actions
    16:32:49 /shop/wp-admin/options-general.php?page=wpsupercache&tab=debug Not caching wp-admin requests.

  6. ncklln
    Posted 4 years ago #

    ...just had 'internal server error' messages on the site (including admin when I tried to log in) which was scary. Found a page that was already logged in to WPSC and switched super-caching off - now it's fine again.

    The cacheing is great when it works, but it doesn't seem to work often - the cache was filled up earlier today (presumably by a spider) and it worked great, but all the files were gone an hour later (i had expiry time set to 360000 seconds)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic