WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP Super Cache] Post not caching

[Plugin: WP Super Cache] Post not caching

Viewing 10 replies - 1 through 10 (of 10 total)
  • That’s bizarre, your config looks fine. You could try debugging wp_cache_ob_callback() in wp-cache-phase2.php with error_log() statements to figure out where the caching stops.

    Here is what I’m getting just before the conditional on line 167:
    $new_cache: true
    $file_expired: false
    $mtime: 1219846211
    (time() – $mtime): 546

    So that entire conditional is skipped. Any ideas?

    I just upgraded to the latest version (0.7.1) and it’s still not working.

    I think i’m having the same issue, how do i know if wp-super cache is working? I don’t see my url ending with .html..

    anyidea on how to make sure?

    solidnuts: when you are NOT logged in, view the source on a page or post on your site and look at the very end. It adds some HTML comments to let you know what it’s doing.

    Thanks for the reply.

    I checked and all i found was

    </body>
    </html>

    <!– Dynamic Page Served (once) in 0.289 seconds –>

    Same problem as me. It’s not caching, it’s serving the dynamic page over and over. Do you have a link to where this is happening? Can you get me a list of the plugins you use?

    I disabled WP Google Analytics and it seems to be working. Unfortunately, this is my plugin and I don’t have time to sort out the conflict right now. Does anyone have any idea what it might be?

    aaroncampbell – the only thing I can see from your plugin that might cause a problem is that you use output buffering. I see an ob_start() but no ob_end_flush(), That’s probably it ..

    donncha: I tried turning that part off (that’s only if it parses links to add code to external ones), and it still didn’t work. I’ll try to play with it at some point and figure it out.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: WP Super Cache] Post not caching’ is closed to new replies.