Support » Plugin: WP Super Cache » [Plugin: WP Super Cache] Only index.html getting cached. Non empty GET request using disqus

  • It seems only my index page is getting cached by super cache, not individual pages or posts.

    I’m on Nginx using Brian Mercer’s config suggestions and I’m using the Disqus comment system.

    The debug log says:

    03:52:18 /2010/one-of-my-post-titles Setting up WordPress actions
    03:52:18 /2010/one-of-my-post-titles Supercache caching disabled. Only using wp-cache. Non empty GET request.
    03:52:18 /2010/one-of-my-post-titles Created output buffer
    03:52:18 /2010/one-of-my-post-titles Output buffer callback
    03:52:18 /2010/one-of-my-post-titles supercache dir: /usr/local/nginx/mysite/htdocs/wp-content/cache/supercache/
    03:52:18 /2010/one-of-my-post-titles Supercache disabled: GET or feed detected or disabled by config.

    Is it because of Disqus? Anything else I should check or information you need? Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Donncha O Caoimh


    Are you using Apache as a reverse proxy? Is Nginx requesting each page with a GET parameter added at the end?

    Nginx is running directly. No Apache involved.

    Brian Mercer took a look and updated his config example and all the pages are now being created. Hooray! However, it looks like PHP is still getting hit rather than Nginx tossing the html files directly. I’m wondering if this is caused by Disqus because of the sync_comments at the end of the request.

    22:34:55 /about supercache dir: /usr/local/nginx/example/htdocs/wp-content/cache/supercache/
    22:34:55 /about No wp-cache file exists. Must generate a new one.
    22:34:55 /about In WP Cache Phase 2
    22:34:55 /about Setting up WordPress actions
    22:34:55 /about Created output buffer
    22:34:55 /about supercache dir: /usr/local/nginx/example/htdocs/wp-content/cache/supercache/
    22:34:55 /about scheduled wp_cache_gc for 10 seconds time.
    22:34:55 /about Output buffer callback
    22:34:55 /about supercache dir: /usr/local/nginx/example/htdocs/wp-content/cache/supercache/
    22:34:55 /about Anonymous user detected. Only creating Supercache file.
    22:34:55 /about supercache dir: /usr/local/nginx/example/htdocs/wp-content/cache/supercache/
    22:34:55 /about Gzipping buffer.
    22:34:55 /about Writing non-gzipped buffer to supercache file.
    22:34:55 /about Writing gzipped buffer to supercache file.
    22:34:55 /about Renamed temp supercache file to /usr/local/nginx/example/htdocs/wp-content/cache/supercache/
    22:34:55 /about Renamed temp supercache gz file to /usr/local/nginx/example/htdocs/wp-content/cache/supercache/www.example.c
    22:34:55 /about Writing gzip content headers. Sending buffer to browser
    22:34:56 /about?cf_action=sync_comments&post_id=2 supercache dir: /usr/local/nginx/example/htdocs/wp-content/cache/supercache/
    22:34:56 /about?cf_action=sync_comments&post_id=2 Served page from supercache file using PHP.

    Did a test with ab. A static file on the server was generating 2666 req/s while the wordpress page was serving 170 req/s…so PHP’s in there somewhere. 🙂 Thanks.

    Plugin Author Donncha O Caoimh


    Looks like that sync comment could be a problem, but is that request generated by Javascript executed by the browser? Is that url requested when you run Apache ab?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: WP Super Cache] Only index.html getting cached. Non empty GET request using disqus’ is closed to new replies.