WP Super Cache
No closing html tag. Not caching. (5 posts)

  1. ivnus
    Posted 3 years ago #

    I'm running a NGINX dev server and having problems getting WP Super Cache to load on my wordpress network. I have turn on debugging and disable every single plugin, checked the theme for closing html, but still getting the same error messages. Is there anything I'm missing, maybe the options in my PHP config such as output_buffering, zlib compression.

    Error Message:
    02:09:56 / Cookie detected: wordpress_logged_in_f3
    02:09:56 / supercache dir: /*/feed/
    02:09:56 / No wp-cache file exists. Must generate a new one.
    02:09:57 / Cookie detected: wordpress_logged_in_f3
    02:09:57 / In WP Cache Phase 2
    02:09:57 / Setting up WordPress actions
    02:09:57 / Supercache caching disabled. Only using wp-cache. Non empty GET request.
    02:09:57 / Created output buffer
    02:09:58 / Output buffer callback
    02:09:58 / Buffer is blank. Output buffer may have been corrupted by another plugin or this is a redirected URL. Look for text 'ob_start' in the files of your plugins directory.
    02:09:58 / No closing html tag. Not caching.
    02:09:58 / wp_cache_shutdown_callback: collecting meta data.
    02:09:58 / Sending 'Content-Type: text/html; charset="UTF-8"' header.
    02:09:58 / Did not write meta file: wp-cache-feeded46d183b3201da133143f5ac6d89ab8.meta ** *0* **


  2. Donncha O Caoimh
    Plugin Author

    Posted 3 years ago #

    Try turn off that output buffering and zlib compression. The plugin caches compressed pages anyway which is better.

  3. Rahul Bansal
    Posted 3 years ago #


    I have posted better Nginx config for WP Super Cache plugins.

    If your WordPress network is using Subdirectories, try this - http://rtcamp.com/tutorials/wordpress-multisite-nginx-config-subdirectories-wp-super-cache/

    If you are using Subdomains/domain mapping, try this - http://rtcamp.com/tutorials/nginx-wordpress-multisite-subdomains-domain-mapping-wp-super-cache/

    Both of above handles gzip and few more things in better way.
    IMHO it will be better to use nginx's gzip functionality.

    Also, both my above config uses Nginx map, which speed up static file-handling on network magically.

  4. ivnus
    Posted 3 years ago #

    Thank you for your replies. I will try this Donncha. Is there any possibility of adding NGINX support to this plugin? Would be really nice feature.

    rahul286, do you have a configuration file for:
    WordPress Network using Subdirectories/domain mapping and WP Super Cache?

  5. ivnus
    Posted 3 years ago #

    Still no luck, I've disabled every plugin, tried all combinations of zlib, output_buffer, on/off, 4096. No luck.

    Is there anything else I can try?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic