Support » Plugin: WP Super Cache » [Plugin: WP Super Cache] Need to clear cache before new post will appear

  • Need to clear cache before new post will appear in Google Chrome, and also need to clear cache before RSS feed will be pull out in RSS Graffiti and (Facebook Application) that will update automatically in my Facebook Fanpage. If I not clear cache, the the Apps will not update the post into my Facebook Fanpage.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Donncha O Caoimh


    Enable debugging and check that it deletes the cached files when you make a post.

    I dont know how to check it 🙁

    Btw I already enable it, and how long that I need to wait to see the difference?

    Plugin Author Donncha O Caoimh


    Publish a post and the debug log should say that it’s clearing cache files. It’s timestamped too so you can check when it happened.

    Same issue here. Home page does not update whatsoever under the new version when new posts are published :(.

    I should note that this affects the feed as well – the RSS feed is not updated either until the cache is cleared, and XML Sitemap Generator for WordPress 3.2.7 will throw errors about rebuilding the sitemap (but rebuilding the sitemap manually after I delete the cache works just fine).

    I am reverting back to 1.0 for now, preload mode off, extra homepage checks on. I can confirm the the homepage of the site is being cached as a supercache file, not sure if preload wasn’t working correctly for that somehow in 1.1 for me?

    Sephage, same problem here, need to clear the cache first and the feed will be updated as I am using RSS Graffiti that automatically updating into my facebook fanpage. Now I am losing too many traffic as the RSS not updated.

    Btw where to to download 1.0? I also need to revert it back as my adnetwork asking me to boost traffic for my site back 🙁

    I have no time to checking the problem like Donncha telling me, because I have to work somemore, and my author updating my site everyday.

    I only can turn on debugging and put your email to send the problem. And Im sure you can check this out.

    @cuppyz – try this link:

    It seems to be working for me after reverting to 1.0, but will need to wait until tomorrow to test it with scheduled posts, due to my schedule. Be aware that you might need to revert the .htaccess code if you’re using mod rewrites (I did that just to be safe). Good luck!

    @sephage, thank you so much! 🙂

    @donncha O Caoimh, as not I’m alone facing this issue, maybe the latest version got some problem with it, and after this release is stable, I will upgrade it because I want to use the 1.0 version back 🙂

    Plugin Author Donncha O Caoimh


    cuppyz – I can’t debug it as I don’t see the problem on my sites. That’s why I need you and others to look at the debug log and tell me if it deletes cache files. It’s not that hard to understand, especially if you look at the timestamps and it explicitly says “deleting cache files” or something like that.

    I also started noticing this a few weeks ago. Scheduled posts were publishing, but the homepage, etc. was never being refreshed. 3 days of posts were not showing up, because the homepage was never being refreshed (though, I have cache timeout at 3600 seconds), which is still confusing….

    I ended up turning on the option:

    Clear all cache files when a post or page is published or updated

    to fix this issue. Which it did, at the expense of clearing my whole cache, which is what I was having to do manually, to get new posts to show up.

    But now, I’m having load issues, so I’m turning it back off.

    Hopefully, I don’t see the previous issue of the homepage never refreshing again.

    If so, I will try to do as you say, and turn on the debug options and publish a test post…

    Plugin Author Donncha O Caoimh


    Try the development version, it’s very stable. More details here:

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: WP Super Cache] Need to clear cache before new post will appear’ is closed to new replies.