WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP Super Cache] Mod Rewrite rules cannot be updated

[Plugin: WP Super Cache] Mod Rewrite rules cannot be updated

  • Under Mod Rewrite Rules, I get this message:

    You must have BEGIN and END markers in /home/user/public_html/blogdirectory/.htaccess for the auto update to work. They look like this and surround the main WordPress mod_rewrite rules:

    # BEGIN WordPress RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] # END WordPress

    Refresh this page when you have updated your .htaccess file.

    I’m not sure what to do here, I edit the .htaccess file, and add this line of code in, but it doesn’t work: # BEGIN WordPress RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] # END WordPress

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have the same problem. Can someone please gives us some guidance?

    I have the same message on the plugin setting page. When I create an .htaccess file in the root directory for my blog it screws everything up. My blog is not in the root directory of my website though…

    OK have figured it out.

    The settings page is misleading in that the code should be written thus:

    # BEGIN WordPress
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    i.e. on new lines, if you copy and paste it from the settings page, it’s on one line and will not work. So I created an .htaccess file in the root directory of my blog, inserted the above refreshed the page then it worked. Hope that helps.

    I have the same issue today and it’s done well thank you pinkbeats

    I’m using WP 2.7 with WP-Supercache 0.9.3.1 installed.

    I tried pinkbeats tips and always ends with Mod Rewrite rules cannot be updated’ warning.

    I’ve tried all of the this plugin suggestions wrote inside the plugin and always ends with Error 500 Internal Server Error.

    Please be advise.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: WP Super Cache] Mod Rewrite rules cannot be updated’ is closed to new replies.
Skip to toolbar