Support » Plugin: WP Super Cache » [Plugin: WP Super Cache] Leverage Browser Caching

  • WP Super Cache is a great plugin .. .but after i went to .. It shows that for good speed ,”Leverage Broser Caching” , After searching more i found that the expiry date in my site is below 24 hours , I tried to copy paste several codes in .htaccess file but the whole site .It said “Internal Server error : 500” .Is there an option in WP super Cache that I am missing?

Viewing 3 replies - 1 through 3 (of 3 total)
  • GRMetrix reports that browser caching is enabled at all my sites that use WP Super Cache. Your issue probably is due to web server configuration.

    Web servers can be selectively configured to enable web browser caching for each type of file. So in your case, for example, browser caching might be enabled for some types of files, such as image files, but not for others such as stylesheet or JavaScript files. Furthermore, the files that do not have browser caching enabled may be related to advertising, such as Google AdSense. Web browser caching generally is not enabled for advertising files, so advertisements can be changed.

    The first troubleshooting step is to check the GTmetrix report to see which types of files are not leveraging browser caching. If they are related to ads, that will be by design and the only fix will be to remove the advertising. If instead they are files being served by your web server, then provide your web hosting tech support staff with a list of the file types.

    I contacted the web-server ,they said its running on nginx and chaching is enabled.After that i copy-pasted several codes in the .htaccess file to ‘leverage browser caching ‘ But the site crashed saying ‘Internal Server Error |588 ‘.
    Can you give me the non-clashing code for the .htaccess file.

    i have just run the GTmetrix plugin, good, but there are issues which are linked directly to WP which cant be fixed!! lol

    it also says i dont have leverage browser caching yet I know I do !


    can you show me the htaccess file I had same issue and it was so easily fixed I had added a line which should not have been there lol


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: WP Super Cache] Leverage Browser Caching’ is closed to new replies.