WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP Super Cache] Infinite redirect loop when accessing https://

[Plugin: WP Super Cache] Infinite redirect loop when accessing https://

  • Hi Donncha,

    I’ve found a pretty nasty bug in wp-super cache. There’s an infinite redirect loop when you go to the “https” version of a blog.

    For instance, https://wyday.com/blog never loads (after about 20 seconds you’ll see a message saying it’s redirecting in such a way that it will never load). The http version of the site loads perfectly: http://wyday.com/blog,

    When I disable wp-supercache this problem goes away.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Looks like your cache files aren’t being served either. I reloaded a few times and the cache generation time changed each time.

    Can you try the development version on the download page? Make sure you delete the supercache rules in your .htaccess first and regenerate them.

    You know what, I just tested disabling all plugins on our live server (instead of the development serer), and I found that the https redirect bug is in the wordpress core, not due to your plugin.

    I apologize.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: WP Super Cache] Infinite redirect loop when accessing https://’ is closed to new replies.
Skip to toolbar