Support » Plugins and Hacks » [Plugin: WP Super Cache] how-to keep shopping cart dynamic?

  • RavanH

    (@ravanh)


    Hi,

    Some available shopping cart plugins like Quick Shop and eShop provide a cart widget and/or have some cart+checkout pages. Is there some documentation on how to make WP Super Cache keep only those parts (widget plus checkout pages) dynamic and still do caching on the rest?

    In the FAQ’s I found some info on < !–mfunc .. > and < !–mincl .. > that look useful but I have no idea how to implement these tricks on existing plugin code. Ofcourse it all depends on the particular plugin but is it at all possible? Or should I approach this differently?

    Thanks for any info 🙂

    http://wordpress.org/extend/plugins/wp-super-cache/

Viewing 15 replies - 16 through 30 (of 32 total)
  • That should work. You should try debug the plugin by searching for the constant in wp-cache-phase2.php and using error_log()

    Thanks, I’ll dive into it this week and let you know what comes out.

    Having a similar problem to RavanH. Where the mincl and mfunc seems to die or when a cached version of a post is served.

    Here’s a test post:
    http://deadlydragonsound.com/wp/records-for-sale/6286

    we have modified single.php with the following:

    <!--mclude displaybuylink.inc.php-->
    <?php include_once( ABSPATH .'/../includes/displaybuylink.inc.php' ); ?>
    <!--/mclude-->			
    
    <!-- use this code to display the buy link -->
    <!--mfunc displayBuyLink3($recordID)-->
    <?php displayBuyLink3($recordID); ?>
    <!--/mfunc-->

    it works fine uncached (try the usual throwing in ?asdf123 or some junk at end of URL to see it working — it will display a red “BUY” button)

    I did the suggestion from Donncha:
    $wp_super_cache_late_init to 1 in wp-content/wp-cache-config.php

    and that at least shows some errors, which indicate to me that the function is cached – I think?

    If I change it back to 0, it just dies at <!–mfunc when I view source.

    WordPress 2.9.1 with WP Super Cache 0.9.9 set to Half-on.

    Thanks in advance for any help!

    Paul – the displayBuyLink3() function isn’t defined when the cache is displayed unless you use the late init feature. Cache files are normally displayed really early.

    Thanks as always for the speedy replies Donncha.
    We changed the wp-cache-config.php to have:
    $wp_super_cache_late_init = 1;

    It hasn’t helped so far. Is there documentation somewhere on how to use the late_init feature?

    If we can’t sort it out, it’s not a deal-breaker. We’ll try going with javascript or maybe just exclude all pages of this category to be non-cached by excluding the category string… though it sure would be nice to keep some caching on all those posts.

    Thanks again
    Paul

    Paul – the developer docs listed above have docs on the late init feature.

    Is there a way to disable caching for the sidebar and footer?

    I tried adding sidebar.php and footer.php into the “Add here strings (not a filename) that forces a page not to be cached.” section but it doesn’t work.

    I would like to know that too,
    when I use mfunc, page stop loading when trying to execute php code (at the included file)

    saharusa – you have to enable the “late init” feature. It’s in the developer docs.

    pinobolino – that won’t work. You need to use the mfunc functions. Read the readme.txt

    Hi donncha,
    It is working with late_init but only if i set:
    $cache_compression = 0;
    if I let in enable (i’m using half on) I get blank page with IE and content encoding error with FF.

    Maybe because gzip already enabled by default on my server ?

    It might be, but the plugin tries very hard to figure out if compression is enabled on the server. I’ll try to look at this next week but in the meantime it’s probably better to leave compression off 🙂

    Great, I’m looking forward you test results.

    Just to let you know, I tried with versions 0.9.8, 0.9.9 and dev, got same results with all.

    Also, if you any help, server configuration details, just say so, I’ll be happy to help.

    Ok, got this fixed in trunk. Try the development version. That should work better for you!

    I confirm, now detection works fine and files are being served from cache with trunk version.

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘[Plugin: WP Super Cache] how-to keep shopping cart dynamic?’ is closed to new replies.