Support » Plugin: WP Super Cache » [Plugin: WP Super Cache] Home page not updated immediately after new posts

  • For some reason, when publishing a new post, the homepage isn’t updated right away with the new post. I can navigate directly to the new post, but it takes 5-10 minutes for that post to show on the homepage.

    I enabled logging and see that WP Supercache deletes the cache files right away:

    21:56:22 /wp-admin/post.php Clearing cache for post 23903 on post edit.
    21:56:22 /wp-admin/post.php Post change: deleting cache files in /var/www/html/wp-content/cache/supercache/www.domain.com/
    21:56:22 /wp-admin/post.php rebuild_or_gc: rename to /var/www/html/wp-content/cache/supercache/www.domain.com/index.html.needs-rebuild
    21:56:22 /wp-admin/post.php rebuild_or_gc: rename to /var/www/html/wp-content/cache/supercache/www.domain.com/index.html.gz.needs-rebuild
    21:56:22 /wp-admin/post.php rebuild_or_gc: deleted /var/www/html/wp-content/cache/supercache/www.domain.com/index.html
    21:56:22 /wp-admin/post.php rebuild_or_gc: deleted /var/www/html/wp-content/cache/supercache/www.domain.com/index.html.gz

    There are no errors reported, and the timestamp on the index.html and index.html.gz are changed. However, the files are the exact same size as they were before the rebuild, and the new post is not on the page. It’s only after about 5 or 10 minutes that the post will show up on the page.

    MySQL query caching is not enabled on the server. I’m not sure where to look next to try to fix this problem. Can anyone point me in the right direction?

    TIA, Jeremy

    http://wordpress.org/extend/plugins/wp-super-cache/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Donncha O Caoimh

    (@donncha)

    That’s weird. Got any sort of object caching going on? DB cache reloaded or similar? I don’t think it’s a problem with supercache anyway.

    No, I don’t have DB cache (or any other caching plugin) installed. As far as I know there is no other caching happening.

    One other thing I noticed is that even though the files have a new timestamp, the page itself is old. For instance, I just made a post, and the file on the server has a timestamp of 11:52am, but inside the file itself is:

    <!– Cached page generated by WP-Super-Cache on 2010-10-31 11:46:01 –>

    It’s like the file has been touched but not regenerated.

    Any other ideas you can think of? I’m completely stumped on this one.

    Thanks, Jeremy

    I think I just found the reason. I went into the options and unchecked the ‘Cache rebuild’ option in the ‘Miscellaneous’ section under the Advanced tab and the caching is now working as expected. When a post is made it now immediately updates the homepage.

    Thanks, Jeremy

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: WP Super Cache] Home page not updated immediately after new posts’ is closed to new replies.