WordPress.org

Support

Support » Plugins and Hacks » WP Super Cache » [Plugin: WP Super Cache] half on mode does not work in a wordpress installation

[Plugin: WP Super Cache] half on mode does not work in a wordpress installation

  • half on mode does not work in a wordpress installation.
    i have enabled debug in both installations.
    these are wp.localhost and wp.kukmara.ru .
    wp.localhost do not work , wp.kukmara.ru works.
    both are 3.0th version.
    wp.localhost is fresh install, no content added.
    how i see that it does not work:

    1. dinarkurbanov.wp.kukmara.ru , which work, shows 0.225 seconds time of loading in httpfox. wp.localhost shows 0.632 seconds.
    ie works slower.

    2. at dinarkurbanov.wp.kukmara.ru i have
    WP-Super-Cache: WP-Cache
    in wp.localhost it is not here.

    that’s all.

    at end of content both have
    <!– Dynamic page generated in 2.516 seconds. –>
    <!– Cached page generated by WP-Super-Cache on 2010-09-13 17:03:46 –>
    and
    <!– Dynamic page generated in 0.429 seconds. –>
    <!– Cached page generated by WP-Super-Cache on 2010-09-13 13:34:26 –>
    .

    debug outputs are different:
    of which works:

    13:17:03 / wp-cache file exists: /var/www/saytlar/kukmararuwpmu/wp-content/cache/blogs/dinarkurbanov.wp.kukmara.ru/wp-cache-dinarkurbanov.wp.kukmara.ru2811a7a69ea8f73b7366ab78aeff092a.html
    13:17:03 / Serving wp-cache static file
    13:17:03 / exit request
    13:17:04 /786b352bcb6964fe3253681027cf600e.css?t=2066636294 supercache dir: /var/www/saytlar/kukmararuwpmu/wp-content/cache/supercache/dinarkurbanov.wp.kukmara.ru/786b352bcb6964fe3253681027cf600e.css/
    13:17:04 /786b352bcb6964fe3253681027cf600e.css?t=2066636294 No wp-cache file exists. Must generate a new one.
    13:17:04 /786b352bcb6964fe3253681027cf600e.css?t=2066636294 In WP Cache Phase 2
    13:17:04 /786b352bcb6964fe3253681027cf600e.css?t=2066636294 Setting up WordPress actions
    13:17:04 /786b352bcb6964fe3253681027cf600e.css?t=2066636294 Supercache caching disabled. Only using wp-cache. Non empty GET request.
    13:17:04 /786b352bcb6964fe3253681027cf600e.css?t=2066636294 Created output buffer
    13:17:04 /wp-cron.php?doing_wp_cron In WP Cache Phase 2
    13:17:04 /wp-cron.php?doing_wp_cron Setting up WordPress actions
    13:17:04 /wp-cron.php?doing_wp_cron Not caching POST request.
    13:17:05 /wp-cron.php?doing_wp_cron Cache garbage collection.
    13:17:05 /wp-cron.php?doing_wp_cron Cleaning expired cache files in /var/www/saytlar/kukmararuwpmu/wp-content/cache/blogs/dinarkurbanov.wp.kukmara.ru/
    13:17:05 /wp-cron.php?doing_wp_cron Doing GC on supercache dir: /var/www/saytlar/kukmararuwpmu/wp-content/cache/supercache
    13:17:05 /786b352bcb6964fe3253681027cf600e.css?t=2066636294 DONOTCACHEPAGE defined. Caching disabled.

    of which do not work:

    13:16:54 / supercache dir: /var/www/localhost/test/wpmu/wp-content/cache/supercache/wp.localhost/
    13:16:54 / No wp-cache file exists. Must generate a new one.
    13:16:54 / In WP Cache Phase 2
    13:16:54 / Setting up WordPress actions
    13:16:54 / Created output buffer
    13:16:54 / scheduled wp_cache_gc for 10 seconds time.
    13:16:55 / Output buffer callback
    13:16:55 / supercache dir: /var/www/localhost/test/wpmu/wp-content/cache/supercache/wp.localhost/
    13:16:55 / supercache dir: /var/www/localhost/test/wpmu/wp-content/cache/supercache/wp.localhost/
    13:16:55 / Writing non-gzipped buffer to wp-cache cache file.
    13:16:55 / Renamed temp wp-cache file to /var/www/localhost/test/wpmu/wp-content/cache/wp-cache-wp.localhost1fbfa4ed208a87a1b41148c485b5f69d.html
    13:16:55 / Sending buffer to browser
    13:16:55 / Writing meta file: /var/www/localhost/test/wpmu/wp-content/cache/meta/wp-cache-wp.localhost1fbfa4ed208a87a1b41148c485b5f69d.meta

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Donncha O Caoimh

    @donncha

    Looks like it wrote the cache file correctly, and in the first debug listing above it served a cache file, but from a different domain.

    Are you using domain mapping or multiple blogs on one install?

    yes , i use, but i think it is correct domain, i said about wp.kukmara.ru but tested dinarkurbanov.wp.kukmara.ru because they are same wordpress, but dinarkurbanov.wp.kukmara.ru has more content. and i have tested wp.localhost also with fusion theme. even if wp.localhost has same theme, less plugins, less content, it works slower. and these sites have different configurations in wp-config.php: wp.localhost’s has

    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );

    that are not in wp.kukmara.ru’s,
    wp.kukmara.ru’s has

    define('VHOST', 'yes');
    define( 'SUNRISE', 'on' );
    define( "WP_USE_MULTIPLE_DB", false );

    that are not in wp.localhost’s.

    bump 🙂 . i have tried also to install development version downloaded today to that wp installation, that mode, called “legacy” now i think, still works slow in the installation.

    Plugin Author Donncha O Caoimh

    @donncha

    I don’t know what to say, best thing you can do is try to profile your site by using error_log() to dump when PHP gets to certain code. Maybe you’ll be able to pinpoint a bottleneck?

    code in
    } elseif ( file_exists( $cache_file ) ) {
    section does not run. files do not exist. wp-content/cache/blogs directory does not exist. file named wp-cache-wp.localhost1fbfa4ed208a87a1b41148c485b5f69d.html is in wp-content/cache/ and directory “meta” is near it.
    in working installation there is “blog” directory, no “meta” dir is near it nor in “blog”. and many directories with domains’ names in “blog”.
    btw bug report: there are deleted blogs’ directories in “blog”.

    btw i have tested whether code runs with header( ‘debug: ok’ ); and httpfox .

    i was wrong, these installations are different versions. wp.kukmara.ru does not have editing category slug.

    i have installed today to test newest wp ie 3.0.1 and newest super cache ie 0.9.9.6 and configured its config file copiing commands from old config file, but legacy cache again did not work, then i have tried to copy
    define('VHOST', 'yes');
    because only it is in config of installation where legacy cache works what is not in the test instalation config.
    and legacy cache has started to work! )

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: WP Super Cache] half on mode does not work in a wordpress installation’ is closed to new replies.
Skip to toolbar