WordPress.org

Forums

WP Super Cache
Error 404 when previewing scheduled posts (3 posts)

  1. Daniel Ribeiro
    Member
    Posted 2 years ago #

    Hello everybody.

    I'm using this amazing plug-in and it really helps me, but it have a very little bug that I imagine it's easy to fix.

    When I schedule a post for a future date, then I click in the "View post" link, this link sends me to the permalink URL of the blog. But my post it's not published yet, so it returns a 404 error.

    My WP Super Cache is configured to threat logged in users like anonymous users, so it serves me a supercache file even I am logged in.

    So, if I add a "?preview=true" after the permalink, i can see the page normally.

    So, my suggestion is: When a post is scheduled to a future date, add the querystring ?preview=true in the "View" links of the WP Panel.

    Thanks!

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    The plugin really should disable the anonymous setting when a post is previewed. Added to my TODO list.

  3. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    AH, interesting. There's no easy way of detecting if you're looking at a future post or not at the time when the plugin makes you anonymous. There is a check for the preview parameter though. That's the best you'll get.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic